summaryrefslogtreecommitdiffstats
path: root/writerfilter/CppunitTest_writerfilter_filters_test.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /writerfilter/CppunitTest_writerfilter_filters_test.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'writerfilter/CppunitTest_writerfilter_filters_test.mk')
-rw-r--r--writerfilter/CppunitTest_writerfilter_filters_test.mk61
1 files changed, 61 insertions, 0 deletions
diff --git a/writerfilter/CppunitTest_writerfilter_filters_test.mk b/writerfilter/CppunitTest_writerfilter_filters_test.mk
new file mode 100644
index 000000000..a08c66675
--- /dev/null
+++ b/writerfilter/CppunitTest_writerfilter_filters_test.mk
@@ -0,0 +1,61 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#*************************************************************************
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#*************************************************************************
+
+$(eval $(call gb_CppunitTest_CppunitTest,writerfilter_filters_test))
+
+$(eval $(call gb_CppunitTest_use_external,writerfilter_filters_test,boost_headers))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,writerfilter_filters_test, \
+ writerfilter/qa/cppunittests/filters-test/filters-test \
+))
+
+ifeq ($(DISABLE_CVE_TESTS),TRUE)
+$(eval $(call gb_CppunitTest_add_defs,writerfilter_filters_test,\
+ -DDISABLE_CVE_TESTS \
+))
+endif
+
+$(eval $(call gb_CppunitTest_use_libraries,writerfilter_filters_test, \
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+ test \
+ unotest \
+ vcl \
+ writerfilter \
+))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,writerfilter_filters_test))
+
+$(eval $(call gb_CppunitTest_use_ure,writerfilter_filters_test))
+$(eval $(call gb_CppunitTest_use_vcl,writerfilter_filters_test))
+
+$(eval $(call gb_CppunitTest_use_components,writerfilter_filters_test,\
+ configmgr/source/configmgr \
+ framework/util/fwk \
+ i18npool/util/i18npool \
+ svtools/util/svt \
+ ucb/source/core/ucb1 \
+ ucb/source/ucp/file/ucpfile1 \
+ writerfilter/util/writerfilter \
+ vcl/vcl.common \
+))
+
+
+
+$(eval $(call gb_CppunitTest_use_configuration,writerfilter_filters_test))
+
+# we need to explicitly depend on library writerfilter because it is not implied
+# by a link relation
+$(call gb_CppunitTest_get_target,writerfilter_filters_test) : $(call gb_Library_get_target,writerfilter)
+
+# vim: set noet sw=4 ts=4: