summaryrefslogtreecommitdiffstats
path: root/writerperfect/Library_writerperfect.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /writerperfect/Library_writerperfect.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'writerperfect/Library_writerperfect.mk')
-rw-r--r--writerperfect/Library_writerperfect.mk60
1 files changed, 60 insertions, 0 deletions
diff --git a/writerperfect/Library_writerperfect.mk b/writerperfect/Library_writerperfect.mk
new file mode 100644
index 000000000..64df2cba9
--- /dev/null
+++ b/writerperfect/Library_writerperfect.mk
@@ -0,0 +1,60 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+$(eval $(call gb_Library_Library,writerperfect))
+
+$(eval $(call gb_Library_add_defs,writerperfect,\
+ -DWRITERPERFECT_DLLIMPLEMENTATION \
+))
+
+$(eval $(call gb_Library_set_include,writerperfect, \
+ -I$(SRCDIR)/writerperfect/inc \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_Library_use_externals,writerperfect,\
+ boost_headers \
+ odfgen \
+ revenge \
+))
+
+$(eval $(call gb_Library_use_sdk_api,writerperfect))
+
+$(eval $(call gb_Library_use_libraries,writerperfect,\
+ comphelper \
+ cppu \
+ cppuhelper \
+ sal \
+ sot \
+ svx \
+ tl \
+ ucbhelper \
+ utl \
+ vcl \
+ xo \
+))
+
+$(eval $(call gb_Library_add_exception_objects,writerperfect,\
+ writerperfect/source/common/DirectoryStream \
+ writerperfect/source/common/DocumentHandler \
+ writerperfect/source/common/WPFTEncodingDialog \
+ writerperfect/source/common/WPXSvInputStream \
+))
+
+# vim: set noet sw=4 ts=4: