summaryrefslogtreecommitdiffstats
path: root/writerperfect/Module_writerperfect.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 09:06:44 +0000
commited5640d8b587fbcfed7dd7967f3de04b37a76f26 (patch)
tree7a5f7c6c9d02226d7471cb3cc8fbbf631b415303 /writerperfect/Module_writerperfect.mk
parentInitial commit. (diff)
downloadlibreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.tar.xz
libreoffice-ed5640d8b587fbcfed7dd7967f3de04b37a76f26.zip
Adding upstream version 4:7.4.7.upstream/4%7.4.7upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'writerperfect/Module_writerperfect.mk')
-rw-r--r--writerperfect/Module_writerperfect.mk60
1 files changed, 60 insertions, 0 deletions
diff --git a/writerperfect/Module_writerperfect.mk b/writerperfect/Module_writerperfect.mk
new file mode 100644
index 000000000..c09dc27b1
--- /dev/null
+++ b/writerperfect/Module_writerperfect.mk
@@ -0,0 +1,60 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+$(eval $(call gb_Module_Module,writerperfect))
+
+$(eval $(call gb_Module_add_targets,writerperfect,\
+ $(if $(ENABLE_WASM_STRIP_BASIC_CALC_DRAW_MATH_IMPRESS),, \
+ Library_wpftcalc \
+ Library_wpftdraw \
+ Library_wpftimpress \
+ ) \
+ Library_wpftwriter \
+ Library_writerperfect \
+ UIConfig_writerperfect \
+))
+
+$(eval $(call gb_Module_add_l10n_targets,writerperfect,\
+ AllLangMoTarget_wpt \
+))
+
+$(eval $(call gb_Module_add_check_targets,writerperfect,\
+ CppunitTest_writerperfect_stream \
+ CppunitTest_writerperfect_wpftimport \
+))
+
+$(eval $(call gb_Module_add_slowcheck_targets,writerperfect,\
+ CppunitTest_writerperfect_calc \
+ CppunitTest_writerperfect_draw \
+ $(if $(SYSTEM_EPUBGEN),,CppunitTest_writerperfect_epubexport) \
+ CppunitTest_writerperfect_import \
+ CppunitTest_writerperfect_impress \
+ CppunitTest_writerperfect_writer \
+ Library_wpftqahelper \
+))
+
+$(eval $(call gb_Module_add_uicheck_targets,writerperfect,\
+ UITest_writerperfect_epubexport \
+))
+
+# screenshots
+$(eval $(call gb_Module_add_screenshot_targets,writerperfect,\
+ CppunitTest_writerperfect_dialogs_test \
+))
+# vim: set noet sw=4 ts=4: