summaryrefslogtreecommitdiffstats
path: root/bean/Jar_officebean.mk
diff options
context:
space:
mode:
Diffstat (limited to 'bean/Jar_officebean.mk')
-rw-r--r--bean/Jar_officebean.mk39
1 files changed, 39 insertions, 0 deletions
diff --git a/bean/Jar_officebean.mk b/bean/Jar_officebean.mk
new file mode 100644
index 000000000..7bc8561ab
--- /dev/null
+++ b/bean/Jar_officebean.mk
@@ -0,0 +1,39 @@
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#
+
+$(eval $(call gb_Jar_Jar,officebean))
+
+$(eval $(call gb_Jar_use_jars,officebean,\
+ libreoffice \
+))
+
+$(eval $(call gb_Jar_set_packageroot,officebean,com))
+
+$(eval $(call gb_Jar_add_sourcefiles,officebean,\
+ bean/com/sun/star/comp/beans/ContainerFactory \
+ bean/com/sun/star/comp/beans/Controller \
+ bean/com/sun/star/comp/beans/Frame \
+ bean/com/sun/star/comp/beans/HasConnectionException \
+ bean/com/sun/star/comp/beans/InvalidArgumentException \
+ bean/com/sun/star/comp/beans/JavaWindowPeerFake \
+ bean/com/sun/star/comp/beans/LocalOfficeConnection \
+ bean/com/sun/star/comp/beans/LocalOfficeWindow \
+ bean/com/sun/star/comp/beans/NativeConnection \
+ bean/com/sun/star/comp/beans/NativeService \
+ bean/com/sun/star/comp/beans/NoConnectionException \
+ bean/com/sun/star/comp/beans/NoDocumentException \
+ bean/com/sun/star/comp/beans/OfficeConnection \
+ bean/com/sun/star/comp/beans/OfficeDocument \
+ bean/com/sun/star/comp/beans/OfficeWindow \
+ bean/com/sun/star/comp/beans/OOoBean \
+ bean/com/sun/star/comp/beans/SystemWindowException \
+ bean/com/sun/star/comp/beans/Wrapper \
+ bean/com/sun/star/comp/beans/CallWatchThread \
+))