summaryrefslogtreecommitdiffstats
path: root/bridges/CustomTarget_gcc3_linux_arm.mk
diff options
context:
space:
mode:
Diffstat (limited to 'bridges/CustomTarget_gcc3_linux_arm.mk')
-rw-r--r--bridges/CustomTarget_gcc3_linux_arm.mk25
1 files changed, 25 insertions, 0 deletions
diff --git a/bridges/CustomTarget_gcc3_linux_arm.mk b/bridges/CustomTarget_gcc3_linux_arm.mk
new file mode 100644
index 000000000..327f1e06a
--- /dev/null
+++ b/bridges/CustomTarget_gcc3_linux_arm.mk
@@ -0,0 +1,25 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CustomTarget_CustomTarget,bridges/source/cpp_uno/gcc3_linux_arm))
+
+$(call gb_CustomTarget_get_target,bridges/source/cpp_uno/gcc3_linux_arm) : \
+ $(call gb_CustomTarget_get_workdir,bridges/source/cpp_uno/gcc3_linux_arm)/armhelper.objectlist
+
+$(call gb_CustomTarget_get_workdir,bridges/source/cpp_uno/gcc3_linux_arm)/armhelper.o : \
+ $(SRCDIR)/bridges/source/cpp_uno/gcc3_linux_arm/armhelper.S \
+ | $(call gb_CustomTarget_get_workdir,bridges/source/cpp_uno/gcc3_linux_arm)/.dir
+ $(gb_CXX) -c -o $@ $< -fPIC
+
+$(call gb_CustomTarget_get_workdir,bridges/source/cpp_uno/gcc3_linux_arm)/armhelper.objectlist : \
+ $(call gb_CustomTarget_get_workdir,bridges/source/cpp_uno/gcc3_linux_arm)/armhelper.o \
+ | $(call gb_CustomTarget_get_workdir,bridges/source/cpp_uno/gcc3_linux_arm)/.dir
+ echo $< > $@
+
+# vim: set noet sw=4 ts=4: