summaryrefslogtreecommitdiffstats
path: root/cli_ure/Package_cli_basetypes_copy.mk
diff options
context:
space:
mode:
Diffstat (limited to 'cli_ure/Package_cli_basetypes_copy.mk')
-rw-r--r--cli_ure/Package_cli_basetypes_copy.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/cli_ure/Package_cli_basetypes_copy.mk b/cli_ure/Package_cli_basetypes_copy.mk
new file mode 100644
index 000000000..75abab150
--- /dev/null
+++ b/cli_ure/Package_cli_basetypes_copy.mk
@@ -0,0 +1,18 @@
+
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Package_Package,cli_basetypes_copy,$(INSTROOT)))
+
+# duplicate copy to work around CLR DLL finding brain damage
+$(eval $(call gb_Package_add_files,cli_basetypes_copy,$(SDKDIRNAME)/bin,\
+ $(LIBO_URE_LIB_FOLDER)/cli_basetypes.dll \
+))
+
+# vim: set noet sw=4 ts=4: