summaryrefslogtreecommitdiffstats
path: root/cppu/CppunitTest_cppu_test_cppumaker.mk
diff options
context:
space:
mode:
Diffstat (limited to 'cppu/CppunitTest_cppu_test_cppumaker.mk')
-rw-r--r--cppu/CppunitTest_cppu_test_cppumaker.mk29
1 files changed, 29 insertions, 0 deletions
diff --git a/cppu/CppunitTest_cppu_test_cppumaker.mk b/cppu/CppunitTest_cppu_test_cppumaker.mk
new file mode 100644
index 000000000..c812d94de
--- /dev/null
+++ b/cppu/CppunitTest_cppu_test_cppumaker.mk
@@ -0,0 +1,29 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CppunitTest_CppunitTest,cppu_test_cppumaker))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,cppu_test_cppumaker, \
+ cppu/qa/cppumaker/test_cppumaker \
+))
+
+$(eval $(call gb_CppunitTest_use_external,cppu_test_cppumaker,boost_headers))
+
+$(eval $(call gb_CppunitTest_use_libraries,cppu_test_cppumaker, \
+ cppu \
+ sal \
+))
+
+$(eval $(call gb_CppunitTest_use_internal_comprehensive_api,cppu_test_cppumaker, \
+ cppu_qa_cppumaker_types \
+ udkapi \
+))
+
+# vim: set noet sw=4 ts=4: