summaryrefslogtreecommitdiffstats
path: root/cppu/Library_unsafe_uno_uno.mk
diff options
context:
space:
mode:
Diffstat (limited to 'cppu/Library_unsafe_uno_uno.mk')
-rw-r--r--cppu/Library_unsafe_uno_uno.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/cppu/Library_unsafe_uno_uno.mk b/cppu/Library_unsafe_uno_uno.mk
new file mode 100644
index 000000000..9733f7216
--- /dev/null
+++ b/cppu/Library_unsafe_uno_uno.mk
@@ -0,0 +1,24 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,unsafe_uno_uno))
+
+$(eval $(call gb_Library_use_udk_api,unsafe_uno_uno))
+
+$(eval $(call gb_Library_use_libraries,unsafe_uno_uno,\
+ purpenvhelper \
+ sal \
+))
+
+$(eval $(call gb_Library_add_exception_objects,unsafe_uno_uno,\
+ cppu/source/UnsafeBridge/UnsafeBridge \
+))
+
+# vim: set noet sw=4 ts=4: