summaryrefslogtreecommitdiffstats
path: root/cppuhelper/InternalUnoApi_cppuhelper.mk
diff options
context:
space:
mode:
Diffstat (limited to 'cppuhelper/InternalUnoApi_cppuhelper.mk')
-rw-r--r--cppuhelper/InternalUnoApi_cppuhelper.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/cppuhelper/InternalUnoApi_cppuhelper.mk b/cppuhelper/InternalUnoApi_cppuhelper.mk
new file mode 100644
index 000000000..d2849b0a3
--- /dev/null
+++ b/cppuhelper/InternalUnoApi_cppuhelper.mk
@@ -0,0 +1,20 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_InternalUnoApi_InternalUnoApi,cppuhelper,cppuhelper/unotypes))
+
+$(eval $(call gb_InternalUnoApi_use_api,cppuhelper,\
+ udkapi \
+))
+
+$(eval $(call gb_InternalUnoApi_add_idlfiles,cppuhelper,cppuhelper/detail,\
+ XExceptionThrower \
+))
+
+# vim:set noet sw=4 ts=4: