summaryrefslogtreecommitdiffstats
path: root/cpputools/Executable_uno.mk
diff options
context:
space:
mode:
Diffstat (limited to 'cpputools/Executable_uno.mk')
-rw-r--r--cpputools/Executable_uno.mk33
1 files changed, 33 insertions, 0 deletions
diff --git a/cpputools/Executable_uno.mk b/cpputools/Executable_uno.mk
new file mode 100644
index 000000000..ba3b22fb6
--- /dev/null
+++ b/cpputools/Executable_uno.mk
@@ -0,0 +1,33 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Executable_Executable,uno))
+
+$(eval $(call gb_Executable_use_internal_comprehensive_api,uno,\
+ udkapi \
+))
+
+$(eval $(call gb_Executable_use_libraries,uno,\
+ cppu \
+ cppuhelper \
+ sal \
+ salhelper \
+))
+
+$(eval $(call gb_Executable_use_externals,uno,\
+ libxml2 \
+))
+
+$(eval $(call gb_Executable_add_exception_objects,uno,\
+ cpputools/source/unoexe/unoexe \
+))
+
+$(eval $(call gb_Executable_add_default_nativeres,uno))
+
+# vim:set noet sw=4 ts=4: