summaryrefslogtreecommitdiffstats
path: root/debian/patches/debian-hardened-buildflags-no-LO-fstack-protector-strong.diff
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/debian-hardened-buildflags-no-LO-fstack-protector-strong.diff')
-rw-r--r--debian/patches/debian-hardened-buildflags-no-LO-fstack-protector-strong.diff32
1 files changed, 32 insertions, 0 deletions
diff --git a/debian/patches/debian-hardened-buildflags-no-LO-fstack-protector-strong.diff b/debian/patches/debian-hardened-buildflags-no-LO-fstack-protector-strong.diff
new file mode 100644
index 000000000..00ae5c56a
--- /dev/null
+++ b/debian/patches/debian-hardened-buildflags-no-LO-fstack-protector-strong.diff
@@ -0,0 +1,32 @@
+don't hardcode -fstack-protector-strong in configure.ac/gbuild. We get the
+hardening flags from dpkg-buildflags anyway.
+
+diff --git a/solenv/gbuild/platform/com_GCC_defs.mk b/solenv/gbuild/platform/com_GCC_defs.mk
+index 712a61df544f..0d50f538ba7b 100644
+--- a/solenv/gbuild/platform/com_GCC_defs.mk
++++ b/solenv/gbuild/platform/com_GCC_defs.mk
+@@ -67,7 +67,6 @@ gb_CFLAGS_COMMON := \
+ -fmessage-length=0 \
+ -fno-common \
+ -pipe \
+- $(if $(filter EMSCRIPTEN,$(OS)),-fno-stack-protector,-fstack-protector-strong) \
+
+ gb_CXXFLAGS_COMMON := \
+ -Wall \
+@@ -82,7 +81,6 @@ gb_CXXFLAGS_COMMON := \
+ -fmessage-length=0 \
+ -fno-common \
+ -pipe \
+- $(if $(filter EMSCRIPTEN,$(OS)),-fno-stack-protector,-fstack-protector-strong) \
+
+ ifeq ($(HAVE_WDEPRECATED_COPY_DTOR),TRUE)
+ gb_CXXFLAGS_COMMON += -Wdeprecated-copy-dtor
+@@ -136,8 +134,6 @@ endif
+ gb_VISIBILITY_FLAGS_CXX := -fvisibility-inlines-hidden
+ gb_CXXFLAGS_COMMON += $(gb_VISIBILITY_FLAGS_CXX)
+
+-gb_LinkTarget_LDFLAGS += $(if $(filter EMSCRIPTEN,$(OS)),-fno-stack-protector,-fstack-protector-strong)
+-
+ ifneq ($(gb_ENABLE_PCH),)
+ ifeq ($(COM_IS_CLANG),TRUE)
+ # Clang by default includes in the PCH timestamps of the files it was