summaryrefslogtreecommitdiffstats
path: root/debian/patches/no-check-if-root.diff
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/no-check-if-root.diff')
-rw-r--r--debian/patches/no-check-if-root.diff30
1 files changed, 30 insertions, 0 deletions
diff --git a/debian/patches/no-check-if-root.diff b/debian/patches/no-check-if-root.diff
new file mode 100644
index 000000000..1fc9b199a
--- /dev/null
+++ b/debian/patches/no-check-if-root.diff
@@ -0,0 +1,30 @@
+--- a/Makefile.in 2017-07-28 06:09:37.072183489 +0000
++++ b/Makefile.in 2017-10-18 12:43:59.215567467 +0000
+@@ -58,18 +58,6 @@ else # MAKE_RESTARTS
+
+ .DEFAULT_GOAL := build
+
+-# Nested test is to check if the systemd-detect-virt command doesn't exist or it reports we're not
+-# in a container:
+-check-if-root:
+- @if test ! `uname` = 'Haiku' -a `id -u` = 0; then \
+- if test ! -x "$$(command -v systemd-detect-virt)" || ! systemd-detect-virt -c -q; then \
+- echo; \
+- echo 'Building LibreOffice as root is a very bad idea, use a regular user.'; \
+- echo; \
+- exit 1; \
+- fi \
+- fi
+-
+ gb_Side ?= host
+
+ include $(BUILDDIR)/config_$(gb_Side).mk
+@@ -252,7 +244,7 @@ endif
+ #
+ # Bootstrap
+ #
+-bootstrap: check-if-root compilerplugins
++bootstrap: compilerplugins
+
+ #
+ # Build