summaryrefslogtreecommitdiffstats
path: root/debian/tests/patches/disable-db-tests.diff
diff options
context:
space:
mode:
Diffstat (limited to 'debian/tests/patches/disable-db-tests.diff')
-rw-r--r--debian/tests/patches/disable-db-tests.diff130
1 files changed, 130 insertions, 0 deletions
diff --git a/debian/tests/patches/disable-db-tests.diff b/debian/tests/patches/disable-db-tests.diff
new file mode 100644
index 000000000..7d148b9f1
--- /dev/null
+++ b/debian/tests/patches/disable-db-tests.diff
@@ -0,0 +1,130 @@
+diff -urN smoketest-old/data/Test_DB.xml smoketest/data/Test_DB.xml
+--- a/smoketest-old/data/Basic/Standard/Test_DB.xml 2011-12-20 16:05:52.000000000 +0000
++++ b/smoketest/data/Basic/Standard/Test_DB.xml 2011-12-29 23:09:08.000000000 +0000
+@@ -30,9 +30,6 @@
+
+ const cMessageDatabaseService = "Database Service"
+ const cMessageDatabaseOpen = "Open Database"
+-const cMessageDatabaseInsert = "Insert record into Database"
+-const cMessageDatabaseDelete = "Delete record from Database"
+-const cMessageDatabaseSeek = "Read other record from Database"
+ const cMessageDatabaseClose = "Close Database"
+
+ Sub TestDB
+@@ -81,48 +78,6 @@
+ LogTestResult( "Database "+ cMessageDatabaseService, TRUE )
+ End If
+
+- gCurrentTestCase = cDBInsert
+- sCurrentMessage = cMessageDatabaseInsert
+-
+- oRowSet.ActiveConnection = oDBConnection
+-
+- oRowSet.CommandType = com.sun.star.sdb.CommandType.COMMAND
+- oRowSet.Command = "SELECT * FROM " + sTable
+- oRowSet.execute()
+-
+- oRowSet.moveToInsertRow
+- oRowSet.updateString(5, sTestString)
+-
+- oRowSet.insertRow()
+- nRowCount=oRowSet.RowCount
+-
+- oRowSet.moveToCurrentRow()
+-
+- bResult = (oRowSet.getString(5) = sTestString)
+- LogTestResult( "Database "+ cMessageDatabaseInsert, bResult )
+-
+- 'delete only if insert passed
+-
+- if (bResult) Then
+- gCurrentTestCase = cDBDelete
+- sCurrentMessage = cMessageDatabaseDelete
+- oRowSet.deleteRow()
+- bResult = (nRowCount - oRowSet.RowCount = 0)
+- if ( bResult ) Then
+- oRowSet.next()
+- bResult = (nRowCount - oRowSet.RowCount = 1)
+- End If
+- LogTestResult( "Database "+ cMessageDatabaseDelete, bResult )
+- End If
+-
+- ' read other record
+-
+- gCurrentTestCase = cDBSeek
+- sCurrentMessage = cMessageDatabaseSeek
+- oRowSet.first()
+- bResult = not (oRowSet.getString(5) = sTestString)
+- LogTestResult( "Database "+ cMessageDatabaseSeek, bResult )
+-
+ gCurrentTestCase = cDBClose
+ sCurrentMessage = cMessageDatabaseClose
+ oDBConnection.Dispose()
+diff --git a/dbaccess/Module_dbaccess.mk b/dbaccess/Module_dbaccess.mk
+index 204854748ec1..992ae1ed17c2 100644
+--- a/dbaccess/Module_dbaccess.mk
++++ b/dbaccess/Module_dbaccess.mk
+@@ -32,63 +32,11 @@ $(eval $(call gb_Module_add_l10n_targets,dbaccess,\
+ AllLangMoTarget_dba \
+ ))
+
+-ifneq ($(OS),iOS)
+-ifeq ($(ENABLE_FIREBIRD_SDBC),TRUE)
+-# remove if we have a be file for this
+-ifeq ($(ENDIANNESS),little)
+-$(eval $(call gb_Module_add_check_targets,dbaccess,\
+- CppunitTest_dbaccess_firebird_regression_test \
+-))
+-endif
+-$(eval $(call gb_Module_add_check_targets,dbaccess,\
+- CppunitTest_dbaccess_firebird_test \
+-))
+-endif
+-
+-$(eval $(call gb_Module_add_check_targets,dbaccess,\
+- CppunitTest_dbaccess_dialog_save \
+- CppunitTest_dbaccess_empty_stdlib_save \
+- CppunitTest_dbaccess_nolib_save \
+- CppunitTest_dbaccess_macros_test \
+- CppunitTest_dbaccess_hsqlschema_import \
+-))
+-
+-ifeq ($(ENABLE_JAVA),TRUE)
+-$(eval $(call gb_Module_add_check_targets,dbaccess,\
+- CppunitTest_dbaccess_hsqldb_test \
+- CppunitTest_dbaccess_RowSetClones \
+-))
+-endif
+-
+-# This runs a suite of performance tests on embedded firebird and HSQLDB.
+-# Instructions on running the test can be found in qa/unit/embeddedb_performancetest
+-ifeq ($(ENABLE_FIREBIRD_SDBC),TRUE)
+-ifeq ($(ENABLE_JAVA),TRUE)
+-$(eval $(call gb_Module_add_check_targets,dbaccess,\
+- CppunitTest_dbaccess_embeddeddb_performancetest \
+-))
+-endif
+-endif
+-
+-$(eval $(call gb_Module_add_subsequentcheck_targets,dbaccess,\
+- JunitTest_dbaccess_complex \
+- JunitTest_dbaccess_unoapi \
+-))
+-
+-ifneq ($(DISABLE_PYTHON),TRUE)
+-ifneq ($(ENABLE_JAVA),)
+-$(eval $(call gb_Module_add_subsequentcheck_targets,dbaccess,\
+- PythonTest_dbaccess_python \
+-))
+-endif
+-endif
+-
+ # screenshots
+ $(eval $(call gb_Module_add_screenshot_targets,dbaccess,\
+ CppunitTest_dbaccess_dialogs_test \
+ ))
+
+-endif
+ endif
+
+ # vim: set noet sw=4 ts=4: