summaryrefslogtreecommitdiffstats
path: root/desktop/CppunitTest_desktop_version.mk
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/CppunitTest_desktop_version.mk')
-rw-r--r--desktop/CppunitTest_desktop_version.mk23
1 files changed, 23 insertions, 0 deletions
diff --git a/desktop/CppunitTest_desktop_version.mk b/desktop/CppunitTest_desktop_version.mk
new file mode 100644
index 000000000..c200f39a7
--- /dev/null
+++ b/desktop/CppunitTest_desktop_version.mk
@@ -0,0 +1,23 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CppunitTest_CppunitTest,desktop_version))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,desktop_version, \
+ desktop/qa/deployment_misc/test_dp_version \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,desktop_version, \
+ deploymentmisc \
+ sal \
+))
+
+$(eval $(call gb_CppunitTest_use_udk_api,desktop_version))
+
+# vim: set noet sw=4 ts=4: