summaryrefslogtreecommitdiffstats
path: root/desktop/CustomTarget_soffice.mk
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/CustomTarget_soffice.mk')
-rw-r--r--desktop/CustomTarget_soffice.mk28
1 files changed, 28 insertions, 0 deletions
diff --git a/desktop/CustomTarget_soffice.mk b/desktop/CustomTarget_soffice.mk
new file mode 100644
index 000000000..d56f57162
--- /dev/null
+++ b/desktop/CustomTarget_soffice.mk
@@ -0,0 +1,28 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CustomTarget_CustomTarget,desktop/soffice))
+
+$(call gb_CustomTarget_get_target,desktop/soffice) : \
+ $(call gb_CustomTarget_get_workdir,desktop/soffice)/soffice.sh
+
+$(call gb_CustomTarget_get_workdir,desktop/soffice)/soffice.sh : \
+ $(SRCDIR)/desktop/scripts/soffice.sh \
+ $(BUILDDIR)/config_host.mk \
+ | $(call gb_CustomTarget_get_workdir,desktop/soffice)/.dir
+ $(call gb_Output_announce,$(subst $(WORKDIR)/,,$@),$(true),SED,1)
+ $(call gb_Trace_StartRange,$(subst $(WORKDIR)/,,$@),SED)
+ifneq ($(JITC_PROCESSOR_TYPE),)
+ sed -e "s/^#@JITC_PROCESSOR_TYPE_EXPORT@/export JITC_PROCESSOR_TYPE=$(JITC_PROCESSOR_TYPE)/" $< > $@
+else
+ cp $< $@
+endif
+ $(call gb_Trace_EndRange,$(subst $(WORKDIR)/,,$@),SED)
+
+# vim:set shiftwidth=4 tabstop=4 noexpandtab: