summaryrefslogtreecommitdiffstats
path: root/desktop/Jar_passive_java.mk
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/Jar_passive_java.mk')
-rw-r--r--desktop/Jar_passive_java.mk28
1 files changed, 28 insertions, 0 deletions
diff --git a/desktop/Jar_passive_java.mk b/desktop/Jar_passive_java.mk
new file mode 100644
index 000000000..0c8c4af5b
--- /dev/null
+++ b/desktop/Jar_passive_java.mk
@@ -0,0 +1,28 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Jar_Jar,passive_java))
+
+$(eval $(call gb_Jar_add_sourcefiles,passive_java, \
+ desktop/test/deployment/passive/com/sun/star/comp/test/deployment/Dispatch \
+ desktop/test/deployment/passive/com/sun/star/comp/test/deployment/Provider \
+ desktop/test/deployment/passive/com/sun/star/comp/test/deployment/Services \
+))
+
+$(eval $(call gb_Jar_set_componentfile,passive_java,desktop/test/deployment/passive/passive_java,OXT,passive_generic))
+
+$(eval $(call gb_Jar_set_manifest,passive_java,$(SRCDIR)/desktop/test/deployment/passive/MANIFEST.MF))
+
+$(eval $(call gb_Jar_set_packageroot,passive_java,com))
+
+$(eval $(call gb_Jar_use_jars,passive_java, \
+ libreoffice \
+))
+
+# vim: set noet sw=4 ts=4: