summaryrefslogtreecommitdiffstats
path: root/desktop/UIConfig_deployment.mk
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/UIConfig_deployment.mk')
-rw-r--r--desktop/UIConfig_deployment.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/desktop/UIConfig_deployment.mk b/desktop/UIConfig_deployment.mk
new file mode 100644
index 000000000..80e5e96c1
--- /dev/null
+++ b/desktop/UIConfig_deployment.mk
@@ -0,0 +1,24 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_UIConfig_UIConfig,desktop))
+
+$(eval $(call gb_UIConfig_add_uifiles,desktop,\
+ desktop/uiconfig/ui/dependenciesdialog \
+ desktop/uiconfig/ui/extensionmanager \
+ desktop/uiconfig/ui/extensionmenu \
+ desktop/uiconfig/ui/installforalldialog \
+ desktop/uiconfig/ui/licensedialog \
+ desktop/uiconfig/ui/showlicensedialog \
+ desktop/uiconfig/ui/updatedialog \
+ desktop/uiconfig/ui/updateinstalldialog \
+ desktop/uiconfig/ui/updaterequireddialog \
+))
+
+# vim: set noet sw=4 ts=4: