summaryrefslogtreecommitdiffstats
path: root/desktop/WinResTarget_swriter.mk
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/WinResTarget_swriter.mk')
-rw-r--r--desktop/WinResTarget_swriter.mk27
1 files changed, 27 insertions, 0 deletions
diff --git a/desktop/WinResTarget_swriter.mk b/desktop/WinResTarget_swriter.mk
new file mode 100644
index 000000000..1136c61bb
--- /dev/null
+++ b/desktop/WinResTarget_swriter.mk
@@ -0,0 +1,27 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_WinResTarget_WinResTarget,swriter/launcher))
+
+$(eval $(call gb_WinResTarget_set_include,swriter/launcher,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/sysui/desktop \
+))
+
+$(eval $(call gb_WinResTarget_add_defs,swriter/launcher,\
+ -DRES_APP_ICON=icons/writer_app.ico \
+))
+
+$(eval $(call gb_WinResTarget_add_dependencies,swriter/launcher,\
+ sysui/desktop/icons/writer_app.ico \
+))
+
+$(eval $(call gb_WinResTarget_set_rcfile,swriter/launcher,desktop/win32/source/applauncher/launcher))
+
+# vim: set ts=4 sw=4 et: