summaryrefslogtreecommitdiffstats
path: root/editeng/CppunitTest_editeng_lookuptree.mk
diff options
context:
space:
mode:
Diffstat (limited to 'editeng/CppunitTest_editeng_lookuptree.mk')
-rw-r--r--editeng/CppunitTest_editeng_lookuptree.mk55
1 files changed, 55 insertions, 0 deletions
diff --git a/editeng/CppunitTest_editeng_lookuptree.mk b/editeng/CppunitTest_editeng_lookuptree.mk
new file mode 100644
index 000000000..cdc421123
--- /dev/null
+++ b/editeng/CppunitTest_editeng_lookuptree.mk
@@ -0,0 +1,55 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+$(eval $(call gb_CppunitTest_CppunitTest,editeng_lookuptree))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,editeng_lookuptree, \
+ editeng/qa/lookuptree/lookuptree_test \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,editeng_lookuptree, \
+ xo \
+ basegfx \
+ editeng \
+ lng \
+ svt \
+ tk \
+ vcl \
+ svl \
+ sot \
+ utl \
+ tl \
+ comphelper \
+ ucbhelper \
+ cppuhelper \
+ cppu \
+ sal \
+ salhelper \
+ i18nlangtag \
+ i18nutil \
+))
+
+$(eval $(call gb_CppunitTest_use_externals,editeng_lookuptree,\
+ boost_headers \
+ icuuc \
+))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,editeng_lookuptree))
+
+# vim: set noet sw=4 ts=4: