summaryrefslogtreecommitdiffstats
path: root/extensions/Library_abp.mk
diff options
context:
space:
mode:
Diffstat (limited to 'extensions/Library_abp.mk')
-rw-r--r--extensions/Library_abp.mk58
1 files changed, 58 insertions, 0 deletions
diff --git a/extensions/Library_abp.mk b/extensions/Library_abp.mk
new file mode 100644
index 000000000..85d0942ef
--- /dev/null
+++ b/extensions/Library_abp.mk
@@ -0,0 +1,58 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+#
+
+$(eval $(call gb_Library_Library,abp))
+
+$(eval $(call gb_Library_set_componentfile,abp,extensions/source/abpilot/abp,services))
+
+$(eval $(call gb_Library_set_include,abp,\
+ $$(INCLUDE) \
+ -I$(SRCDIR)/extensions/inc \
+ -I$(SRCDIR)/extensions/source/inc \
+))
+
+$(eval $(call gb_Library_use_external,abp,boost_headers))
+
+$(eval $(call gb_Library_use_sdk_api,abp))
+
+$(eval $(call gb_Library_add_exception_objects,abp,\
+ extensions/source/abpilot/abpfinalpage \
+ extensions/source/abpilot/abspage \
+ extensions/source/abpilot/abspilot \
+ extensions/source/abpilot/admininvokationimpl \
+ extensions/source/abpilot/admininvokationpage \
+ extensions/source/abpilot/datasourcehandling \
+ extensions/source/abpilot/fieldmappingimpl \
+ extensions/source/abpilot/fieldmappingpage \
+ extensions/source/abpilot/moduleabp \
+ extensions/source/abpilot/tableselectionpage \
+ extensions/source/abpilot/typeselectionpage \
+ extensions/source/abpilot/unodialogabp \
+))
+
+$(eval $(call gb_Library_use_libraries,abp,\
+ comphelper \
+ cppuhelper \
+ cppu \
+ sal \
+ sfx \
+ svl \
+ svt \
+ svxcore \
+ svx \
+ tk \
+ tl \
+ utl \
+ vcl \
+ i18nlangtag \
+))
+
+# vim:set noet sw=4 ts=4: