summaryrefslogtreecommitdiffstats
path: root/external/clew/Library_clew.mk
diff options
context:
space:
mode:
Diffstat (limited to 'external/clew/Library_clew.mk')
-rw-r--r--external/clew/Library_clew.mk41
1 files changed, 41 insertions, 0 deletions
diff --git a/external/clew/Library_clew.mk b/external/clew/Library_clew.mk
new file mode 100644
index 000000000..9e664fed5
--- /dev/null
+++ b/external/clew/Library_clew.mk
@@ -0,0 +1,41 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,clew))
+
+$(eval $(call gb_Library_add_defs,clew,\
+ -DCLEW_BUILD \
+))
+
+ifeq ($(OS),LINUX)
+$(eval $(call gb_Library_add_libs,clew,\
+ -ldl \
+ -lrt \
+))
+endif
+
+ifeq ($(OS),MACOSX)
+$(eval $(call gb_Library_add_libs,clew,\
+ -framework OpenCL \
+))
+endif
+
+$(eval $(call gb_Library_add_cobjects,clew,\
+ external/clew/source/clew \
+))
+
+$(eval $(call gb_Library_set_include,clew, \
+ -I$(SRCDIR)/external/clew/source/include \
+ $$(INCLUDE) \
+))
+
+# This is required for module-deps.pl to produce correct dependencies.
+$(eval $(call gb_Library_use_libraries,clew,))
+
+# vim: set noet sw=4 ts=4: