summaryrefslogtreecommitdiffstats
path: root/external/freetype/UnpackedTarball_freetype.mk
diff options
context:
space:
mode:
Diffstat (limited to 'external/freetype/UnpackedTarball_freetype.mk')
-rw-r--r--external/freetype/UnpackedTarball_freetype.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/external/freetype/UnpackedTarball_freetype.mk b/external/freetype/UnpackedTarball_freetype.mk
new file mode 100644
index 000000000..076edb9e3
--- /dev/null
+++ b/external/freetype/UnpackedTarball_freetype.mk
@@ -0,0 +1,21 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_UnpackedTarball_UnpackedTarball,freetype))
+
+$(eval $(call gb_UnpackedTarball_set_tarball,freetype,$(FREETYPE_TARBALL),,freetype))
+
+$(eval $(call gb_UnpackedTarball_add_patches,freetype,\
+ external/freetype/freetype-2.6.5.patch.1 \
+ external/freetype/ubsan.patch \
+))
+
+$(eval $(call gb_UnpackedTarball_set_patchlevel,freetype,0))
+
+# vim: set noet sw=4 ts=4: