summaryrefslogtreecommitdiffstats
path: root/external/gpgmepp/configure.patch
diff options
context:
space:
mode:
Diffstat (limited to 'external/gpgmepp/configure.patch')
-rw-r--r--external/gpgmepp/configure.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/external/gpgmepp/configure.patch b/external/gpgmepp/configure.patch
new file mode 100644
index 000000000..ad3f97e63
--- /dev/null
+++ b/external/gpgmepp/configure.patch
@@ -0,0 +1,34 @@
+--- configure.ac
++++ configure.ac
+@@ -617,6 +617,15 @@
+ AC_SUBST(API__SSIZE_T)
+ AM_SUBST_NOTMAKE(API__SSIZE_T)
+
++# Try to find a thread-safe version of ttyname().
++gnupg_REPLACE_TTYNAME_R
++if test "$ac_cv_func_ttyname_r" != yes; then
++ AC_MSG_WARN([
++***
++*** ttyname() is not thread-safe and ttyname_r() does not exist
++***])
++fi
++
+ # Checks for compiler features.
+ if test "$GCC" = yes; then
+ CFLAGS="$CFLAGS -Wall -Wcast-align -Wshadow -Wstrict-prototypes"
+@@ -677,15 +686,6 @@
+
+ AC_FUNC_FSEEKO
+
+-# Try to find a thread-safe version of ttyname().
+-gnupg_REPLACE_TTYNAME_R
+-if test "$ac_cv_func_ttyname_r" != yes; then
+- AC_MSG_WARN([
+-***
+-*** ttyname() is not thread-safe and ttyname_r() does not exist
+-***])
+-fi
+-
+ # Try to find a thread-safe version of getenv().
+ have_thread_safe_getenv=no
+ jm_GLIBC21