summaryrefslogtreecommitdiffstats
path: root/external/libstaroffice
diff options
context:
space:
mode:
Diffstat (limited to 'external/libstaroffice')
-rw-r--r--external/libstaroffice/ExternalPackage_libstaroffice.mk22
-rw-r--r--external/libstaroffice/ExternalProject_libstaroffice.mk54
-rw-r--r--external/libstaroffice/Library_staroffice.mk114
-rw-r--r--external/libstaroffice/Makefile7
-rw-r--r--external/libstaroffice/Module_libstaroffice.mk31
-rw-r--r--external/libstaroffice/README3
-rw-r--r--external/libstaroffice/UnpackedTarball_libstaroffice.mk32
-rw-r--r--external/libstaroffice/inc/pch/precompiled_staroffice.cxx12
-rw-r--r--external/libstaroffice/inc/pch/precompiled_staroffice.hxx59
-rw-r--r--external/libstaroffice/libstaroffice-bundled-soname.patch.011
-rw-r--r--external/libstaroffice/rpath.patch10
11 files changed, 355 insertions, 0 deletions
diff --git a/external/libstaroffice/ExternalPackage_libstaroffice.mk b/external/libstaroffice/ExternalPackage_libstaroffice.mk
new file mode 100644
index 000000000..939fbbc2c
--- /dev/null
+++ b/external/libstaroffice/ExternalPackage_libstaroffice.mk
@@ -0,0 +1,22 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_ExternalPackage_ExternalPackage,libstaroffice,libstaroffice))
+
+$(eval $(call gb_ExternalPackage_use_external_project,libstaroffice,libstaroffice))
+
+ifeq ($(OS),MACOSX)
+$(eval $(call gb_ExternalPackage_add_file,libstaroffice,$(LIBO_LIB_FOLDER)/libstaroffice-0.0.0.dylib,src/lib/.libs/libstaroffice-0.0.0.dylib))
+else ifeq ($(OS),WNT)
+$(eval $(call gb_ExternalPackage_add_file,libstaroffice,$(LIBO_LIB_FOLDER)/libstaroffice-0.0.dll,src/lib/.libs/libstaroffice-0.0.dll))
+else ifeq ($(DISABLE_DYNLOADING),)
+$(eval $(call gb_ExternalPackage_add_file,libstaroffice,$(LIBO_LIB_FOLDER)/libstaroffice-0.0-lo.so.0,src/lib/.libs/libstaroffice-0.0-lo.so.0.0.$(STAROFFICE_VERSION_MICRO)))
+endif
+
+# vim: set noet sw=4 ts=4:
diff --git a/external/libstaroffice/ExternalProject_libstaroffice.mk b/external/libstaroffice/ExternalProject_libstaroffice.mk
new file mode 100644
index 000000000..a81428e71
--- /dev/null
+++ b/external/libstaroffice/ExternalProject_libstaroffice.mk
@@ -0,0 +1,54 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_ExternalProject_ExternalProject,libstaroffice))
+
+$(eval $(call gb_ExternalProject_use_autoconf,libstaroffice,build))
+
+$(eval $(call gb_ExternalProject_register_targets,libstaroffice,\
+ build \
+))
+
+$(eval $(call gb_ExternalProject_use_externals,libstaroffice,\
+ revenge \
+))
+
+$(call gb_ExternalProject_get_state_target,libstaroffice,build) :
+ $(call gb_Trace_StartRange,libstaroffice,EXTERNAL)
+ $(call gb_ExternalProject_run,build,\
+ export PKG_CONFIG="" \
+ && $(gb_RUN_CONFIGURE) ./configure \
+ --with-pic \
+ $(if $(DISABLE_DYNLOADING), \
+ --enable-static --disable-shared \
+ , \
+ --enable-shared --disable-static \
+ ) \
+ --with-sharedptr=c++11 \
+ --without-docs \
+ --disable-tools \
+ --disable-zip \
+ $(if $(ENABLE_DEBUG),--enable-debug,--disable-debug) \
+ $(if $(verbose),--disable-silent-rules,--enable-silent-rules) \
+ --disable-werror \
+ CXXFLAGS="$(gb_CXXFLAGS) $(call gb_ExternalProject_get_build_flags,libstaroffice)" \
+ $(if $(filter LINUX,$(OS)),$(if $(SYSTEM_REVENGE),, \
+ 'LDFLAGS=-Wl$(COMMA)-z$(COMMA)origin \
+ -Wl$(COMMA)-rpath$(COMMA)\$$$$ORIGIN')) \
+ $(gb_CONFIGURE_PLATFORMS) \
+ $(if $(filter MACOSX,$(OS)),--prefix=/@.__________________________________________________OOO) \
+ && $(MAKE) \
+ $(if $(filter MACOSX,$(OS)),\
+ && $(PERL) $(SRCDIR)/solenv/bin/macosx-change-install-names.pl shl OOO \
+ $(EXTERNAL_WORKDIR)/src/lib/.libs/libstaroffice-0.0.0.dylib \
+ ) \
+ )
+ $(call gb_Trace_EndRange,libstaroffice,EXTERNAL)
+
+# vim: set noet sw=4 ts=4:
diff --git a/external/libstaroffice/Library_staroffice.mk b/external/libstaroffice/Library_staroffice.mk
new file mode 100644
index 000000000..66b35501d
--- /dev/null
+++ b/external/libstaroffice/Library_staroffice.mk
@@ -0,0 +1,114 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,staroffice))
+
+$(eval $(call gb_Library_use_unpacked,staroffice,libstaroffice))
+
+$(eval $(call gb_Library_use_externals,staroffice,\
+ revenge \
+))
+
+$(eval $(call gb_Library_set_warnings_disabled,staroffice))
+
+$(eval $(call gb_Library_set_precompiled_header,staroffice,external/libstaroffice/inc/pch/precompiled_staroffice))
+
+$(eval $(call gb_Library_set_include,staroffice,\
+ -I$(call gb_UnpackedTarball_get_dir,libstaroffice)/inc \
+ -I$(call gb_UnpackedTarball_get_dir,libstaroffice)/src/lib \
+ $$(INCLUDE) \
+))
+
+$(eval $(call gb_Library_add_defs,staroffice,\
+ -DBUILD_STOFF \
+ -D_WINDLL \
+ -DNDEBUG \
+))
+
+$(eval $(call gb_Library_add_generated_exception_objects,staroffice,\
+ UnpackedTarball/libstaroffice/src/lib/SDAParser \
+ UnpackedTarball/libstaroffice/src/lib/SDCParser \
+ UnpackedTarball/libstaroffice/src/lib/SDGParser \
+ UnpackedTarball/libstaroffice/src/lib/SDWParser \
+ UnpackedTarball/libstaroffice/src/lib/SDXParser \
+ UnpackedTarball/libstaroffice/src/lib/STOFFCell \
+ UnpackedTarball/libstaroffice/src/lib/STOFFCellStyle \
+ UnpackedTarball/libstaroffice/src/lib/STOFFChart \
+ UnpackedTarball/libstaroffice/src/lib/STOFFDebug \
+ UnpackedTarball/libstaroffice/src/lib/STOFFDocument \
+ UnpackedTarball/libstaroffice/src/lib/STOFFEntry \
+ UnpackedTarball/libstaroffice/src/lib/STOFFFont \
+ UnpackedTarball/libstaroffice/src/lib/STOFFFrameStyle \
+ UnpackedTarball/libstaroffice/src/lib/STOFFGraphicDecoder \
+ UnpackedTarball/libstaroffice/src/lib/STOFFGraphicEncoder \
+ UnpackedTarball/libstaroffice/src/lib/STOFFGraphicListener \
+ UnpackedTarball/libstaroffice/src/lib/STOFFGraphicShape \
+ UnpackedTarball/libstaroffice/src/lib/STOFFGraphicStyle \
+ UnpackedTarball/libstaroffice/src/lib/STOFFHeader \
+ UnpackedTarball/libstaroffice/src/lib/STOFFInputStream \
+ UnpackedTarball/libstaroffice/src/lib/STOFFList \
+ UnpackedTarball/libstaroffice/src/lib/STOFFListener \
+ UnpackedTarball/libstaroffice/src/lib/STOFFOLEParser \
+ UnpackedTarball/libstaroffice/src/lib/STOFFPageSpan \
+ UnpackedTarball/libstaroffice/src/lib/STOFFParagraph \
+ UnpackedTarball/libstaroffice/src/lib/STOFFParser \
+ UnpackedTarball/libstaroffice/src/lib/STOFFPosition \
+ UnpackedTarball/libstaroffice/src/lib/STOFFPropertyHandler \
+ UnpackedTarball/libstaroffice/src/lib/STOFFSection \
+ UnpackedTarball/libstaroffice/src/lib/STOFFSpreadsheetDecoder \
+ UnpackedTarball/libstaroffice/src/lib/STOFFSpreadsheetEncoder \
+ UnpackedTarball/libstaroffice/src/lib/STOFFSpreadsheetListener \
+ UnpackedTarball/libstaroffice/src/lib/STOFFStarMathToMMLConverter \
+ UnpackedTarball/libstaroffice/src/lib/STOFFStringStream \
+ UnpackedTarball/libstaroffice/src/lib/STOFFSubDocument \
+ UnpackedTarball/libstaroffice/src/lib/STOFFTable \
+ UnpackedTarball/libstaroffice/src/lib/STOFFTextListener \
+ UnpackedTarball/libstaroffice/src/lib/SWFieldManager \
+ UnpackedTarball/libstaroffice/src/lib/StarAttribute \
+ UnpackedTarball/libstaroffice/src/lib/StarBitmap \
+ UnpackedTarball/libstaroffice/src/lib/StarCellAttribute \
+ UnpackedTarball/libstaroffice/src/lib/StarCellFormula \
+ UnpackedTarball/libstaroffice/src/lib/StarCharAttribute \
+ UnpackedTarball/libstaroffice/src/lib/StarEncoding \
+ UnpackedTarball/libstaroffice/src/lib/StarEncodingChinese \
+ UnpackedTarball/libstaroffice/src/lib/StarEncodingJapanese \
+ UnpackedTarball/libstaroffice/src/lib/StarEncodingKorean \
+ UnpackedTarball/libstaroffice/src/lib/StarEncodingOtherKorean \
+ UnpackedTarball/libstaroffice/src/lib/StarEncodingTradChinese \
+ UnpackedTarball/libstaroffice/src/lib/StarEncryption \
+ UnpackedTarball/libstaroffice/src/lib/StarFileManager \
+ UnpackedTarball/libstaroffice/src/lib/StarFormatManager \
+ UnpackedTarball/libstaroffice/src/lib/StarFrameAttribute \
+ UnpackedTarball/libstaroffice/src/lib/StarGraphicAttribute \
+ UnpackedTarball/libstaroffice/src/lib/StarGraphicStruct \
+ UnpackedTarball/libstaroffice/src/lib/StarItem \
+ UnpackedTarball/libstaroffice/src/lib/StarItemPool \
+ UnpackedTarball/libstaroffice/src/lib/StarLanguage \
+ UnpackedTarball/libstaroffice/src/lib/StarLayout \
+ UnpackedTarball/libstaroffice/src/lib/StarObject \
+ UnpackedTarball/libstaroffice/src/lib/StarObjectChart \
+ UnpackedTarball/libstaroffice/src/lib/StarObjectDraw \
+ UnpackedTarball/libstaroffice/src/lib/StarObjectMath \
+ UnpackedTarball/libstaroffice/src/lib/StarObjectModel \
+ UnpackedTarball/libstaroffice/src/lib/StarObjectNumericRuler \
+ UnpackedTarball/libstaroffice/src/lib/StarObjectPageStyle \
+ UnpackedTarball/libstaroffice/src/lib/StarObjectSmallGraphic \
+ UnpackedTarball/libstaroffice/src/lib/StarObjectSmallText \
+ UnpackedTarball/libstaroffice/src/lib/StarObjectSpreadsheet \
+ UnpackedTarball/libstaroffice/src/lib/StarObjectText \
+ UnpackedTarball/libstaroffice/src/lib/StarPageAttribute \
+ UnpackedTarball/libstaroffice/src/lib/StarParagraphAttribute \
+ UnpackedTarball/libstaroffice/src/lib/StarState \
+ UnpackedTarball/libstaroffice/src/lib/StarTable \
+ UnpackedTarball/libstaroffice/src/lib/StarWriterStruct \
+ UnpackedTarball/libstaroffice/src/lib/StarZone \
+ UnpackedTarball/libstaroffice/src/lib/libstaroffice_internal \
+))
+
+# vim: set noet sw=4 ts=4:
diff --git a/external/libstaroffice/Makefile b/external/libstaroffice/Makefile
new file mode 100644
index 000000000..e4968cf85
--- /dev/null
+++ b/external/libstaroffice/Makefile
@@ -0,0 +1,7 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+
+module_directory:=$(dir $(realpath $(firstword $(MAKEFILE_LIST))))
+
+include $(module_directory)/../../solenv/gbuild/partial_build.mk
+
+# vim: set noet sw=4 ts=4:
diff --git a/external/libstaroffice/Module_libstaroffice.mk b/external/libstaroffice/Module_libstaroffice.mk
new file mode 100644
index 000000000..b96bde2b1
--- /dev/null
+++ b/external/libstaroffice/Module_libstaroffice.mk
@@ -0,0 +1,31 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,libstaroffice))
+
+$(eval $(call gb_Module_add_targets,libstaroffice,\
+ UnpackedTarball_libstaroffice \
+))
+
+ifeq ($(COM),MSC)
+
+$(eval $(call gb_Module_add_targets,libstaroffice,\
+ Library_staroffice \
+))
+
+else
+
+$(eval $(call gb_Module_add_targets,libstaroffice,\
+ ExternalPackage_libstaroffice \
+ ExternalProject_libstaroffice \
+))
+
+endif
+
+# vim: set noet sw=4 ts=4:
diff --git a/external/libstaroffice/README b/external/libstaroffice/README
new file mode 100644
index 000000000..957fb4926
--- /dev/null
+++ b/external/libstaroffice/README
@@ -0,0 +1,3 @@
+Library parsing different document file formats of StarOffice.
+
+https://github.com/fosnola/libstaroffice
diff --git a/external/libstaroffice/UnpackedTarball_libstaroffice.mk b/external/libstaroffice/UnpackedTarball_libstaroffice.mk
new file mode 100644
index 000000000..b7d8f4ee7
--- /dev/null
+++ b/external/libstaroffice/UnpackedTarball_libstaroffice.mk
@@ -0,0 +1,32 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_UnpackedTarball_UnpackedTarball,libstaroffice))
+
+$(eval $(call gb_UnpackedTarball_set_tarball,libstaroffice,$(STAROFFICE_TARBALL)))
+
+$(eval $(call gb_UnpackedTarball_set_patchlevel,libstaroffice,0))
+
+$(eval $(call gb_UnpackedTarball_update_autoconf_configs,libstaroffice))
+
+ifneq ($(OS),MACOSX)
+ifneq ($(OS),WNT)
+$(eval $(call gb_UnpackedTarball_add_patches,libstaroffice, \
+ external/libstaroffice/libstaroffice-bundled-soname.patch.0 \
+))
+endif
+endif
+
+ifeq ($(SYSTEM_REVENGE),)
+$(eval $(call gb_UnpackedTarball_add_patches,libstaroffice, \
+ external/libstaroffice/rpath.patch \
+))
+endif
+
+# vim: set noet sw=4 ts=4:
diff --git a/external/libstaroffice/inc/pch/precompiled_staroffice.cxx b/external/libstaroffice/inc/pch/precompiled_staroffice.cxx
new file mode 100644
index 000000000..5e5bfdb72
--- /dev/null
+++ b/external/libstaroffice/inc/pch/precompiled_staroffice.cxx
@@ -0,0 +1,12 @@
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
+/*
+ * This file is part of the LibreOffice project.
+ *
+ * This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/.
+ */
+
+#include "precompiled_staroffice.hxx"
+
+/* vim:set shiftwidth=4 softtabstop=4 expandtab: */
diff --git a/external/libstaroffice/inc/pch/precompiled_staroffice.hxx b/external/libstaroffice/inc/pch/precompiled_staroffice.hxx
new file mode 100644
index 000000000..1ad24c005
--- /dev/null
+++ b/external/libstaroffice/inc/pch/precompiled_staroffice.hxx
@@ -0,0 +1,59 @@
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
+/*
+ * This file is part of the LibreOffice project.
+ *
+ * This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/.
+ */
+
+/*
+ This file has been autogenerated by update_pch.sh. It is possible to edit it
+ manually (such as when an include file has been moved/renamed/removed). All such
+ manual changes will be rewritten by the next run of update_pch.sh (which presumably
+ also fixes all possible problems, so it's usually better to use it).
+
+ Generated on 2019-10-13 10:27:57 using:
+ ./bin/update_pch external/libstaroffice staroffice --cutoff=1 --exclude:system --include:module --include:local
+
+ If after updating build fails, use the following command to locate conflicting headers:
+ ./bin/update_pch_bisect ./external/libstaroffice/inc/pch/precompiled_staroffice.hxx "make external/libstaroffice.build" --find-conflicts
+*/
+
+#if PCH_LEVEL >= 1
+#include <algorithm>
+#include <cctype>
+#include <cmath>
+#include <cstdarg>
+#include <cstdio>
+#include <cstdlib>
+#include <cstring>
+#include <ctype.h>
+#include <functional>
+#include <iomanip>
+#include <iostream>
+#include <limits>
+#include <locale.h>
+#include <map>
+#include <math.h>
+#include <memory>
+#include <set>
+#include <sstream>
+#include <stack>
+#include <string.h>
+#include <string>
+#include <time.h>
+#include <utility>
+#include <vector>
+#endif // PCH_LEVEL >= 1
+#if PCH_LEVEL >= 2
+#endif // PCH_LEVEL >= 2
+#if PCH_LEVEL >= 3
+#include <librevenge-stream/librevenge-stream.h>
+#include <librevenge/librevenge.h>
+#include <libstaroffice/libstaroffice.hxx>
+#endif // PCH_LEVEL >= 3
+#if PCH_LEVEL >= 4
+#endif // PCH_LEVEL >= 4
+
+/* vim:set shiftwidth=4 softtabstop=4 expandtab: */
diff --git a/external/libstaroffice/libstaroffice-bundled-soname.patch.0 b/external/libstaroffice/libstaroffice-bundled-soname.patch.0
new file mode 100644
index 000000000..00b064d10
--- /dev/null
+++ b/external/libstaroffice/libstaroffice-bundled-soname.patch.0
@@ -0,0 +1,11 @@
+--- src/lib/Makefile.in.orig 2015-08-07 14:04:47.646611627 +0200
++++ src/lib/Makefile.in 2015-08-07 14:25:49.888589996 +0200
+@@ -418,7 +418,7 @@
+ AM_CXXFLAGS = -I$(top_srcdir)/inc $(REVENGE_CFLAGS) $(DEBUG_CXXFLAGS) $(ZLIB_CFLAGS) -DBUILD_STAROFFICE=1
+ libstaroffice_@STAROFFICE_MAJOR_VERSION@_@STAROFFICE_MINOR_VERSION@_la_LIBADD = $(REVENGE_LIBS) $(ZLIB_LIBS) @LIBSTAROFFICE_WIN32_RESOURCE@
+ libstaroffice_@STAROFFICE_MAJOR_VERSION@_@STAROFFICE_MINOR_VERSION@_la_DEPENDENCIES = @LIBSTAROFFICE_WIN32_RESOURCE@
+-libstaroffice_@STAROFFICE_MAJOR_VERSION@_@STAROFFICE_MINOR_VERSION@_la_LDFLAGS = $(version_info) -export-dynamic -no-undefined
++libstaroffice_@STAROFFICE_MAJOR_VERSION@_@STAROFFICE_MINOR_VERSION@_la_LDFLAGS = $(version_info) -export-dynamic -no-undefined -release lo
+ libstaroffice_@STAROFFICE_MAJOR_VERSION@_@STAROFFICE_MINOR_VERSION@_la_SOURCES = \
+ SDAParser.cxx \
+ SDAParser.hxx \
diff --git a/external/libstaroffice/rpath.patch b/external/libstaroffice/rpath.patch
new file mode 100644
index 000000000..a73d8ae22
--- /dev/null
+++ b/external/libstaroffice/rpath.patch
@@ -0,0 +1,10 @@
+--- configure
++++ configure
+@@ -15353,6 +15353,7 @@
+ esac
+ ;;
+ esac
++hardcode_libdir_flag_spec_CXX=
+ ;;
+
+ lynxos*)