summaryrefslogtreecommitdiffstats
path: root/external/misc_extensions
diff options
context:
space:
mode:
Diffstat (limited to 'external/misc_extensions')
-rw-r--r--external/misc_extensions/ExtensionPackageSet_misc_extensions.mk16
-rw-r--r--external/misc_extensions/Makefile7
-rw-r--r--external/misc_extensions/Module_misc_extensions.mk16
-rw-r--r--external/misc_extensions/README1
4 files changed, 40 insertions, 0 deletions
diff --git a/external/misc_extensions/ExtensionPackageSet_misc_extensions.mk b/external/misc_extensions/ExtensionPackageSet_misc_extensions.mk
new file mode 100644
index 000000000..b03254845
--- /dev/null
+++ b/external/misc_extensions/ExtensionPackageSet_misc_extensions.mk
@@ -0,0 +1,16 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_ExtensionPackageSet_ExtensionPackageSet,misc_extensions))
+
+ifneq ($(NUMBERTEXT_EXTENSION_PACK),)
+$(eval $(call gb_ExtensionPackageSet_add_extension,misc_extensions,numbertext,$(NUMBERTEXT_EXTENSION_PACK)))
+endif
+
+# vim: set noet sw=4 ts=4:
diff --git a/external/misc_extensions/Makefile b/external/misc_extensions/Makefile
new file mode 100644
index 000000000..e4968cf85
--- /dev/null
+++ b/external/misc_extensions/Makefile
@@ -0,0 +1,7 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+
+module_directory:=$(dir $(realpath $(firstword $(MAKEFILE_LIST))))
+
+include $(module_directory)/../../solenv/gbuild/partial_build.mk
+
+# vim: set noet sw=4 ts=4:
diff --git a/external/misc_extensions/Module_misc_extensions.mk b/external/misc_extensions/Module_misc_extensions.mk
new file mode 100644
index 000000000..86f65c2dd
--- /dev/null
+++ b/external/misc_extensions/Module_misc_extensions.mk
@@ -0,0 +1,16 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,misc_extensions))
+
+$(eval $(call gb_Module_add_targets,misc_extensions,\
+ ExtensionPackageSet_misc_extensions \
+))
+
+# vim: set noet sw=4 ts=4:
diff --git a/external/misc_extensions/README b/external/misc_extensions/README
new file mode 100644
index 000000000..9c6fa2e54
--- /dev/null
+++ b/external/misc_extensions/README
@@ -0,0 +1 @@
+misc_extensions contains some extensions may be downloaded and bundled as-is