summaryrefslogtreecommitdiffstats
path: root/external/msc-externals/Module_msc-externals.mk
diff options
context:
space:
mode:
Diffstat (limited to 'external/msc-externals/Module_msc-externals.mk')
-rw-r--r--external/msc-externals/Module_msc-externals.mk29
1 files changed, 29 insertions, 0 deletions
diff --git a/external/msc-externals/Module_msc-externals.mk b/external/msc-externals/Module_msc-externals.mk
new file mode 100644
index 000000000..07ea3878a
--- /dev/null
+++ b/external/msc-externals/Module_msc-externals.mk
@@ -0,0 +1,29 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,msc-externals))
+
+ifneq ($(BUILD_X64),)
+
+$(eval $(call gb_Module_add_targets,msc-externals,\
+ Package_msvc_dlls \
+))
+
+endif
+
+# Install the universal crts (tdf#108580)
+ifneq ($(UCRT_REDISTDIR),)
+
+$(eval $(call gb_Module_add_targets,msc-externals,\
+ Package_ucrt \
+))
+
+endif
+
+# vim: set noet sw=4 ts=4: