summaryrefslogtreecommitdiffstats
path: root/external/rhino/Module_rhino.mk
diff options
context:
space:
mode:
Diffstat (limited to 'external/rhino/Module_rhino.mk')
-rw-r--r--external/rhino/Module_rhino.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/external/rhino/Module_rhino.mk b/external/rhino/Module_rhino.mk
new file mode 100644
index 000000000..201d3ba9f
--- /dev/null
+++ b/external/rhino/Module_rhino.mk
@@ -0,0 +1,22 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,rhino))
+
+ifneq ($(ENABLE_JAVA),)
+ifneq ($(filter RHINO,$(BUILD_TYPE)),)
+$(eval $(call gb_Module_add_targets,rhino,\
+ ExternalPackage_rhino \
+ ExternalProject_rhino \
+ UnpackedTarball_rhino \
+))
+endif
+endif
+
+# vim: set noet sw=4 ts=4: