summaryrefslogtreecommitdiffstats
path: root/forms/Module_forms.mk
diff options
context:
space:
mode:
Diffstat (limited to 'forms/Module_forms.mk')
-rw-r--r--forms/Module_forms.mk28
1 files changed, 28 insertions, 0 deletions
diff --git a/forms/Module_forms.mk b/forms/Module_forms.mk
new file mode 100644
index 000000000..7ba484b81
--- /dev/null
+++ b/forms/Module_forms.mk
@@ -0,0 +1,28 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,forms))
+
+$(eval $(call gb_Module_add_targets,forms,\
+ Library_frm \
+))
+
+$(eval $(call gb_Module_add_l10n_targets,forms,\
+ AllLangMoTarget_frm \
+))
+
+$(eval $(call gb_Module_add_subsequentcheck_targets,forms,\
+ JunitTest_forms_unoapi_1 \
+ JunitTest_forms_unoapi_2 \
+ JunitTest_forms_unoapi_3 \
+ JunitTest_forms_unoapi_4 \
+ JunitTest_forms_complex \
+))
+
+# vim: set noet sw=4 ts=4: