summaryrefslogtreecommitdiffstats
path: root/i18nlangtag/CppunitTest_i18nlangtag_test_languagetag.mk
diff options
context:
space:
mode:
Diffstat (limited to 'i18nlangtag/CppunitTest_i18nlangtag_test_languagetag.mk')
-rw-r--r--i18nlangtag/CppunitTest_i18nlangtag_test_languagetag.mk40
1 files changed, 40 insertions, 0 deletions
diff --git a/i18nlangtag/CppunitTest_i18nlangtag_test_languagetag.mk b/i18nlangtag/CppunitTest_i18nlangtag_test_languagetag.mk
new file mode 100644
index 000000000..801bfe7b9
--- /dev/null
+++ b/i18nlangtag/CppunitTest_i18nlangtag_test_languagetag.mk
@@ -0,0 +1,40 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CppunitTest_CppunitTest,i18nlangtag_test_languagetag))
+
+$(eval $(call gb_CppunitTest_use_external,i18nlangtag_test_languagetag,boost_headers))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,i18nlangtag_test_languagetag))
+
+$(eval $(call gb_CppunitTest_use_libraries,i18nlangtag_test_languagetag,\
+ i18nlangtag \
+ cppu \
+ cppuhelper \
+ sal \
+))
+
+$(eval $(call gb_CppunitTest_use_externals,i18nlangtag_test_languagetag,\
+ icu_headers \
+ icuuc \
+ liblangtag \
+ libxml2 \
+))
+
+ifneq ($(SYSTEM_LIBLANGTAG),)
+$(eval $(call gb_CppunitTest_add_defs,i18nlangtag_test_languagetag,-DSYSTEM_LIBLANGTAG))
+else
+$(eval $(call gb_CppunitTest_use_package,i18nlangtag_test_languagetag,liblangtag_data))
+endif
+
+$(eval $(call gb_CppunitTest_add_exception_objects,i18nlangtag_test_languagetag,\
+ i18nlangtag/qa/cppunit/test_languagetag \
+))
+
+# vim: set noet sw=4 ts=4: