summaryrefslogtreecommitdiffstats
path: root/i18npool/Executable_gendict.mk
diff options
context:
space:
mode:
Diffstat (limited to 'i18npool/Executable_gendict.mk')
-rw-r--r--i18npool/Executable_gendict.mk28
1 files changed, 28 insertions, 0 deletions
diff --git a/i18npool/Executable_gendict.mk b/i18npool/Executable_gendict.mk
new file mode 100644
index 000000000..82dd5f7b1
--- /dev/null
+++ b/i18npool/Executable_gendict.mk
@@ -0,0 +1,28 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Executable_Executable,gendict))
+
+$(eval $(call gb_Executable_use_libraries,gendict,\
+ sal \
+))
+
+ifeq ($(gb_Side),build)
+ifneq ($(shell grep -e OS=iOS -e OS=ANDROID $(BUILDDIR)/config_host.mk),)
+$(eval $(call gb_Executable_add_cxxflags,gendict,\
+ -DDICT_JA_ZH_IN_DATAFILE \
+))
+endif
+endif
+
+$(eval $(call gb_Executable_add_exception_objects,gendict,\
+ i18npool/source/breakiterator/gendict \
+))
+
+# vim: set noet sw=4 ts=4: