summaryrefslogtreecommitdiffstats
path: root/i18npool/Library_index_data.mk
diff options
context:
space:
mode:
Diffstat (limited to 'i18npool/Library_index_data.mk')
-rw-r--r--i18npool/Library_index_data.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/i18npool/Library_index_data.mk b/i18npool/Library_index_data.mk
new file mode 100644
index 000000000..b00ede9d5
--- /dev/null
+++ b/i18npool/Library_index_data.mk
@@ -0,0 +1,19 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,index_data))
+
+$(eval $(call gb_Library_set_plugin_for_nodep,index_data,i18npool))
+
+$(eval $(call gb_Library_add_generated_exception_objects,index_data,\
+ $(foreach txt,$(wildcard $(SRCDIR)/i18npool/source/indexentry/data/*.txt),\
+ CustomTarget/i18npool/indexentry/$(notdir $(basename $(txt)))) \
+))
+
+# vim: set noet sw=4 ts=4: