summaryrefslogtreecommitdiffstats
path: root/io/Module_io.mk
diff options
context:
space:
mode:
Diffstat (limited to 'io/Module_io.mk')
-rw-r--r--io/Module_io.mk26
1 files changed, 26 insertions, 0 deletions
diff --git a/io/Module_io.mk b/io/Module_io.mk
new file mode 100644
index 000000000..c4a75e74e
--- /dev/null
+++ b/io/Module_io.mk
@@ -0,0 +1,26 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,io))
+
+$(eval $(call gb_Module_add_targets,io,\
+ Library_io \
+))
+
+$(eval $(call gb_Module_add_subsequentcheck_targets,io,\
+ CppunitTest_io_textinputstream \
+))
+
+ifneq (,$(filter Executable_io-testconnection,$(MAKECMDGOALS)))
+$(eval $(call gb_Module_add_targets,io, \
+ Executable_io-testconnection \
+))
+endif
+
+# vim:set noet sw=4 ts=4: