summaryrefslogtreecommitdiffstats
path: root/jurt/Module_jurt.mk
diff options
context:
space:
mode:
Diffstat (limited to 'jurt/Module_jurt.mk')
-rw-r--r--jurt/Module_jurt.mk27
1 files changed, 27 insertions, 0 deletions
diff --git a/jurt/Module_jurt.mk b/jurt/Module_jurt.mk
new file mode 100644
index 000000000..1c0d5baa9
--- /dev/null
+++ b/jurt/Module_jurt.mk
@@ -0,0 +1,27 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,jurt))
+
+ifneq ($(ENABLE_JAVA),)
+
+$(eval $(call gb_Module_add_targets,jurt,\
+ Jar_jurt \
+ Library_jpipe \
+))
+
+ifeq ($(OS),WNT)
+$(eval $(call gb_Module_add_targets,jurt,\
+ Library_jpipx \
+))
+endif
+
+endif
+
+# vim:set noet sw=4 ts=4: