summaryrefslogtreecommitdiffstats
path: root/jvmaccess/Library_jvmaccess.mk
diff options
context:
space:
mode:
Diffstat (limited to 'jvmaccess/Library_jvmaccess.mk')
-rw-r--r--jvmaccess/Library_jvmaccess.mk33
1 files changed, 33 insertions, 0 deletions
diff --git a/jvmaccess/Library_jvmaccess.mk b/jvmaccess/Library_jvmaccess.mk
new file mode 100644
index 000000000..b4ef50a7d
--- /dev/null
+++ b/jvmaccess/Library_jvmaccess.mk
@@ -0,0 +1,33 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Library_Library,jvmaccess))
+
+$(eval $(call gb_Library_add_defs,jvmaccess,\
+ -DJVMACCESS_DLLIMPLEMENTATION \
+))
+
+$(eval $(call gb_Library_use_api,jvmaccess,\
+ udkapi \
+))
+
+$(eval $(call gb_Library_use_libraries,jvmaccess,\
+ cppu \
+ cppuhelper \
+ sal \
+ salhelper \
+))
+
+$(eval $(call gb_Library_add_exception_objects,jvmaccess,\
+ jvmaccess/source/classpath \
+ jvmaccess/source/unovirtualmachine \
+ jvmaccess/source/virtualmachine \
+))
+
+# vim:set noet sw=4 ts=4: