summaryrefslogtreecommitdiffstats
path: root/jvmaccess/workbench/java
diff options
context:
space:
mode:
Diffstat (limited to 'jvmaccess/workbench/java')
-rw-r--r--jvmaccess/workbench/java/TestComponent.java89
-rw-r--r--jvmaccess/workbench/java/makefile.mk34
-rw-r--r--jvmaccess/workbench/java/manifest1
3 files changed, 124 insertions, 0 deletions
diff --git a/jvmaccess/workbench/java/TestComponent.java b/jvmaccess/workbench/java/TestComponent.java
new file mode 100644
index 000000000..8e692a73b
--- /dev/null
+++ b/jvmaccess/workbench/java/TestComponent.java
@@ -0,0 +1,89 @@
+/*
+ * This file is part of the LibreOffice project.
+ *
+ * This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * This file incorporates work covered by the following license notice:
+ *
+ * Licensed to the Apache Software Foundation (ASF) under one or more
+ * contributor license agreements. See the NOTICE file distributed
+ * with this work for additional information regarding copyright
+ * ownership. The ASF licenses this file to you under the Apache
+ * License, Version 2.0 (the "License"); you may not use this file
+ * except in compliance with the License. You may obtain a copy of
+ * the License at http://www.apache.org/licenses/LICENSE-2.0 .
+ */
+
+package com.sun.star.comp.jvmaccess.workbench;
+
+import com.sun.star.comp.loader.FactoryHelper;
+import com.sun.star.lang.XMain;
+import com.sun.star.lang.XMultiServiceFactory;
+import com.sun.star.lang.XServiceInfo;
+import com.sun.star.lang.XSingleServiceFactory;
+import com.sun.star.lang.XTypeProvider;
+import com.sun.star.registry.XRegistryKey;
+import com.sun.star.uno.Type;
+
+/* Deploy this component with pkgchk, and call it with the Basic program
+
+ Sub Main
+ dim args$()
+ o = createunoservice("com.sun.star.comp.jvmaccess.workbench.TestComponent")
+ o.run args$()
+ End Sub
+
+ The name of the context class loader should appear on the console.
+ */
+
+public final class TestComponent implements XTypeProvider, XServiceInfo, XMain {
+ public Type[] getTypes() {
+ return new Type[] { new Type(XTypeProvider.class),
+ new Type(XServiceInfo.class),
+ new Type(XMain.class) };
+ }
+
+ public byte[] getImplementationId() {
+ return new byte[0];
+ }
+
+ public String getImplementationName() {
+ return getClass().getName();
+ }
+
+ public boolean supportsService(String serviceName) {
+ return serviceName.equals(serviceName);
+ }
+
+ public String[] getSupportedServiceNames() {
+ return new String[] { serviceName };
+ }
+
+ public int run(String[] arguments) {
+ System.out.println("context class loader: "
+ + Thread.currentThread().getContextClassLoader());
+ return 0;
+ }
+
+ public static XSingleServiceFactory __getServiceFactory(
+ String implName, XMultiServiceFactory multiFactory, XRegistryKey regKey)
+ {
+ if (implName.equals(TestComponent.class.getName())) {
+ return FactoryHelper.getServiceFactory(TestComponent.class,
+ serviceName, multiFactory,
+ regKey);
+ } else {
+ return null;
+ }
+ }
+
+ public static boolean __writeRegistryServiceInfo(XRegistryKey regKey) {
+ return FactoryHelper.writeRegistryServiceInfo(
+ TestComponent.class.getName(), serviceName, regKey);
+ }
+
+ private static final String serviceName
+ = "com.sun.star.comp.jvmaccess.workbench.TestComponent";
+}
diff --git a/jvmaccess/workbench/java/makefile.mk b/jvmaccess/workbench/java/makefile.mk
new file mode 100644
index 000000000..405eae95d
--- /dev/null
+++ b/jvmaccess/workbench/java/makefile.mk
@@ -0,0 +1,34 @@
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+PRJ = ..$/..
+PRJNAME = jvmaccess
+TARGET = workbench_java
+
+PACKAGE = com$/sun$/star$/comp$/jvmaccess$/workbench
+
+.INCLUDE: settings.mk
+
+JARFILES = ridl.jar jurt.jar
+JAVACLASSFILES = $(CLASSDIR)$/$(PACKAGE)$/TestComponent.class
+JARCLASSDIRS = $(PACKAGE)
+JARTARGET = jvmaccesstestcomponent.jar
+JARCOMPRESS = TRUE
+CUSTOMMANIFESTFILE = manifest
+
+.INCLUDE: target.mk
diff --git a/jvmaccess/workbench/java/manifest b/jvmaccess/workbench/java/manifest
new file mode 100644
index 000000000..73b21eca3
--- /dev/null
+++ b/jvmaccess/workbench/java/manifest
@@ -0,0 +1 @@
+RegistrationClassName: com.sun.star.comp.jvmaccess.workbench.TestComponent