summaryrefslogtreecommitdiffstats
path: root/jvmfwk/CppunitTest_jvmfwk_sunversion.mk
diff options
context:
space:
mode:
Diffstat (limited to 'jvmfwk/CppunitTest_jvmfwk_sunversion.mk')
-rw-r--r--jvmfwk/CppunitTest_jvmfwk_sunversion.mk40
1 files changed, 40 insertions, 0 deletions
diff --git a/jvmfwk/CppunitTest_jvmfwk_sunversion.mk b/jvmfwk/CppunitTest_jvmfwk_sunversion.mk
new file mode 100644
index 000000000..8aa6a2c68
--- /dev/null
+++ b/jvmfwk/CppunitTest_jvmfwk_sunversion.mk
@@ -0,0 +1,40 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t; fill-column: 100 -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CppunitTest_CppunitTest,jvmfwk_sunversion))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,jvmfwk_sunversion, \
+ jvmfwk/qa/unit/sunversion \
+))
+
+$(eval $(call gb_CppunitTest_set_include,jvmfwk_sunversion, \
+ $$(INCLUDE) \
+ -I$(SRCDIR) \
+))
+
+$(eval $(call gb_CppunitTest_use_externals,jvmfwk_sunversion, \
+ libxml2 \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,jvmfwk_sunversion, \
+ sal \
+ salhelper \
+))
+
+$(eval $(call gb_CppunitTest_use_library_objects,jvmfwk_sunversion, \
+ jvmfwk \
+))
+
+ifeq ($(OS),MACOSX)
+$(eval $(call gb_CppunitTest_use_system_darwin_frameworks,jvmfwk_sunversion, \
+ Foundation \
+))
+endif
+
+# vim: set noet sw=4 ts=4: