summaryrefslogtreecommitdiffstats
path: root/librelogo/Module_librelogo.mk
diff options
context:
space:
mode:
Diffstat (limited to 'librelogo/Module_librelogo.mk')
-rw-r--r--librelogo/Module_librelogo.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/librelogo/Module_librelogo.mk b/librelogo/Module_librelogo.mk
new file mode 100644
index 000000000..2e83293cc
--- /dev/null
+++ b/librelogo/Module_librelogo.mk
@@ -0,0 +1,24 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,librelogo))
+
+ifneq ($(filter SCRIPTING,$(BUILD_TYPE)),)
+ifneq ($(DISABLE_PYTHON),TRUE)
+
+$(eval $(call gb_Module_add_targets,librelogo,\
+ CustomTarget_librelogo \
+ Package_librelogo \
+ Package_librelogo_properties \
+))
+
+endif
+endif
+
+# vim: set noet sw=4 ts=4: