summaryrefslogtreecommitdiffstats
path: root/libreofficekit/Module_libreofficekit.mk
diff options
context:
space:
mode:
Diffstat (limited to 'libreofficekit/Module_libreofficekit.mk')
-rw-r--r--libreofficekit/Module_libreofficekit.mk38
1 files changed, 38 insertions, 0 deletions
diff --git a/libreofficekit/Module_libreofficekit.mk b/libreofficekit/Module_libreofficekit.mk
new file mode 100644
index 000000000..bf75f359e
--- /dev/null
+++ b/libreofficekit/Module_libreofficekit.mk
@@ -0,0 +1,38 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Module_Module,libreofficekit))
+
+ifeq ($(OS), $(filter LINUX %BSD SOLARIS, $(OS)))
+
+$(eval $(call gb_Module_add_check_targets,libreofficekit, \
+ CppunitTest_libreofficekit_checkapi \
+))
+
+# tdf#113311 disabled because it can deadlock on shutdown
+#$(eval $(call gb_Module_add_subsequentcheck_targets,libreofficekit,\
+ CppunitTest_libreofficekit_tiledrendering \
+))
+
+ifneq ($(ENABLE_GTK3),)
+$(eval $(call gb_Module_add_targets,libreofficekit,\
+ Library_libreofficekitgtk \
+ Executable_gtktiledviewer \
+))
+endif # ($(ENABLE_GTK3),)
+
+$(eval $(call gb_Module_add_targets,libreofficekit,\
+ $(if $(DISABLE_DYNLOADING),,Executable_tilebench) \
+ Package_selectionhandles \
+ UIConfig_libreofficekit \
+))
+
+endif
+
+# vim: set ts=4 sw=4 et: