summaryrefslogtreecommitdiffstats
path: root/oox/CppunitTest_oox_vba_encryption.mk
diff options
context:
space:
mode:
Diffstat (limited to 'oox/CppunitTest_oox_vba_encryption.mk')
-rw-r--r--oox/CppunitTest_oox_vba_encryption.mk46
1 files changed, 46 insertions, 0 deletions
diff --git a/oox/CppunitTest_oox_vba_encryption.mk b/oox/CppunitTest_oox_vba_encryption.mk
new file mode 100644
index 000000000..ed625f2cc
--- /dev/null
+++ b/oox/CppunitTest_oox_vba_encryption.mk
@@ -0,0 +1,46 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CppunitTest_CppunitTest,oox_vba_encryption))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,oox_vba_encryption,\
+ oox/qa/unit/vba_encryption \
+))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,oox_vba_encryption))
+
+$(eval $(call gb_CppunitTest_use_libraries,oox_vba_encryption,\
+ basegfx \
+ comphelper \
+ cppu \
+ cppuhelper \
+ editeng \
+ expwrap \
+ drawinglayer \
+ msfilter \
+ sal \
+ i18nlangtag \
+ oox \
+ sax \
+ sfx \
+ svl \
+ svt \
+ svx \
+ svxcore \
+ sot \
+ tl \
+ unotest \
+ utl \
+ vcl \
+ xo \
+ xmlscript \
+))
+
+# vim: set noet sw=4 ts=4: