summaryrefslogtreecommitdiffstats
path: root/postprocess/Package_registry.mk
diff options
context:
space:
mode:
Diffstat (limited to 'postprocess/Package_registry.mk')
-rw-r--r--postprocess/Package_registry.mk38
1 files changed, 38 insertions, 0 deletions
diff --git a/postprocess/Package_registry.mk b/postprocess/Package_registry.mk
new file mode 100644
index 000000000..2332e1bfe
--- /dev/null
+++ b/postprocess/Package_registry.mk
@@ -0,0 +1,38 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Package_Package,postprocess_registry,$(patsubst %/,%,$(call gb_XcdTarget_get_target,))))
+
+$(eval $(call gb_Package_add_files,postprocess_registry,$(LIBO_SHARE_FOLDER)/registry,\
+ $(postprocess_XCDS) \
+ $(foreach lang,$(gb_Configuration_LANGS), \
+ Langpack-$(lang).xcd \
+ ) \
+))
+
+$(eval $(foreach lang,$(gb_CJK_LANGS),\
+ $(call gb_Package_add_file,postprocess_registry,$(LIBO_SHARE_FOLDER)/registry/cjk_$(lang).xcd,cjk.xcd) \
+))
+
+$(eval $(foreach lang,$(gb_CTL_LANGS),\
+ $(call gb_Package_add_file,postprocess_registry,$(LIBO_SHARE_FOLDER)/registry/ctl_$(lang).xcd,ctl.xcd) \
+))
+
+$(eval $(foreach lang,$(gb_CTLSEQCHECK_LANGS),\
+ $(call gb_Package_add_file,postprocess_registry,$(LIBO_SHARE_FOLDER)/registry/ctlseqcheck_$(lang).xcd,ctlseqcheck.xcd) \
+))
+
+$(eval $(call gb_Package_add_files,postprocess_registry,$(LIBO_SHARE_FOLDER)/registry/res,\
+ $(foreach lang,$(gb_Configuration_LANGS), \
+ fcfg_langpack_$(lang).xcd \
+ registry_$(lang).xcd \
+ ) \
+))
+
+# vim: set noet sw=4 ts=4: