summaryrefslogtreecommitdiffstats
path: root/pyuno/Executable_python.mk
diff options
context:
space:
mode:
Diffstat (limited to 'pyuno/Executable_python.mk')
-rw-r--r--pyuno/Executable_python.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/pyuno/Executable_python.mk b/pyuno/Executable_python.mk
new file mode 100644
index 000000000..192d54cf9
--- /dev/null
+++ b/pyuno/Executable_python.mk
@@ -0,0 +1,22 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_Executable_Executable,python))
+
+$(eval $(call gb_Executable_use_static_libraries,python,\
+ ooopathutils \
+))
+
+$(eval $(call gb_Executable_add_exception_objects,python,\
+ pyuno/zipcore/python \
+))
+
+$(eval $(call gb_Executable_add_default_nativeres,python))
+
+# vim:set noet sw=4 ts=4: