summaryrefslogtreecommitdiffstats
path: root/pyuno/demo/makefile.mk
diff options
context:
space:
mode:
Diffstat (limited to 'pyuno/demo/makefile.mk')
-rw-r--r--pyuno/demo/makefile.mk60
1 files changed, 60 insertions, 0 deletions
diff --git a/pyuno/demo/makefile.mk b/pyuno/demo/makefile.mk
new file mode 100644
index 000000000..11fe66f31
--- /dev/null
+++ b/pyuno/demo/makefile.mk
@@ -0,0 +1,60 @@
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+PRJNAME=pyuno
+PRJ=..
+
+.INCLUDE : settings.mk
+.INCLUDE : pyversion.mk
+
+ROOT=$(MISC)/pyuno-doc
+
+FILES=\
+ $(ROOT)/python-bridge.html \
+ $(ROOT)/customized_setup.png \
+ $(ROOT)/mode_component.png \
+ $(ROOT)/mode_ipc.png \
+ $(ROOT)/modes.sxd \
+ $(ROOT)/optional_components.png \
+ $(ROOT)/samples/swriter.py \
+ $(ROOT)/samples/swritercomp.py \
+ $(ROOT)/samples/ooextract.py \
+ $(ROOT)/samples/biblioaccess.py \
+ $(ROOT)/samples/swritercompclient.py \
+ $(ROOT)/samples/hello_world_pyuno.zip
+
+
+$(MISC)/pyuno-doc.zip : dirs $(FILES)
+ -rm -f $@
+ cd $(MISC) && zip -r pyuno-doc.zip pyuno-doc
+
+dirs .PHONY :
+ -mkdir $(ROOT)
+ -mkdir $(ROOT)/samples
+
+$(ROOT)/samples/hello_world_pyuno.zip : hello_world_comp.py Addons.xcu
+ -rm -f $@
+ zip $@ hello_world_comp.py Addons.xcu
+
+$(ROOT)/samples/% : %
+ -rm -f $@
+ $(COPY) $? $@
+
+$(ROOT)/% : ../doc/%
+ -rm -f $@
+ $(COPY) $? $@