summaryrefslogtreecommitdiffstats
path: root/ridljar/JunitTest_connections.mk
diff options
context:
space:
mode:
Diffstat (limited to 'ridljar/JunitTest_connections.mk')
-rw-r--r--ridljar/JunitTest_connections.mk28
1 files changed, 28 insertions, 0 deletions
diff --git a/ridljar/JunitTest_connections.mk b/ridljar/JunitTest_connections.mk
new file mode 100644
index 000000000..8c8496e35
--- /dev/null
+++ b/ridljar/JunitTest_connections.mk
@@ -0,0 +1,28 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_JunitTest_JunitTest,ridl_connections))
+
+$(eval $(call gb_Jar_use_customtargets,ridl_connections, \
+ ridljar/javamaker \
+))
+
+$(eval $(call gb_JunitTest_use_jar_classset,ridl_connections,libreoffice))
+
+$(eval $(call gb_JunitTest_add_classpath,ridl_connections,$(call gb_CustomTarget_get_workdir,ridljar/javamaker)))
+
+$(eval $(call gb_JunitTest_add_sourcefiles,ridl_connections,\
+ ridljar/test/com/sun/star/comp/connections/PipedConnection_Test \
+))
+
+$(eval $(call gb_JunitTest_add_classes,ridl_connections,\
+ com.sun.star.comp.connections.PipedConnection_Test \
+))
+
+# vim:set noet sw=4 ts=4: