summaryrefslogtreecommitdiffstats
path: root/ridljar/JunitTest_remote.mk
diff options
context:
space:
mode:
Diffstat (limited to 'ridljar/JunitTest_remote.mk')
-rw-r--r--ridljar/JunitTest_remote.mk37
1 files changed, 37 insertions, 0 deletions
diff --git a/ridljar/JunitTest_remote.mk b/ridljar/JunitTest_remote.mk
new file mode 100644
index 000000000..340618676
--- /dev/null
+++ b/ridljar/JunitTest_remote.mk
@@ -0,0 +1,37 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_JunitTest_JunitTest,ridl_remote))
+
+$(eval $(call gb_Jar_use_customtargets,ridl_remote, \
+ ridljar/javamaker \
+))
+
+$(eval $(call gb_JunitTest_use_jar_classset,ridl_remote,libreoffice))
+
+$(eval $(call gb_JunitTest_add_classpath,ridl_remote,$(call gb_CustomTarget_get_workdir,ridljar/javamaker)))
+
+$(eval $(call gb_JunitTest_add_sourcefiles,ridl_remote,\
+ ridljar/test/com/sun/star/lib/uno/environments/remote/JavaThreadPoolFactory_Test \
+ ridljar/test/com/sun/star/lib/uno/environments/remote/JobQueue_Test \
+ ridljar/test/com/sun/star/lib/uno/environments/remote/TestIWorkAt \
+ ridljar/test/com/sun/star/lib/uno/environments/remote/TestReceiver \
+ ridljar/test/com/sun/star/lib/uno/environments/remote/TestWorkAt \
+ ridljar/test/com/sun/star/lib/uno/environments/remote/ThreadId_Test \
+ ridljar/test/com/sun/star/lib/uno/environments/remote/ThreadPool_Test \
+))
+
+$(eval $(call gb_JunitTest_add_classes,ridl_remote,\
+ com.sun.star.lib.uno.environments.remote.JavaThreadPoolFactory_Test \
+ com.sun.star.lib.uno.environments.remote.JobQueue_Test \
+ com.sun.star.lib.uno.environments.remote.ThreadId_Test \
+ com.sun.star.lib.uno.environments.remote.ThreadPool_Test \
+))
+
+# vim:set noet sw=4 ts=4: