summaryrefslogtreecommitdiffstats
path: root/ridljar/JunitTest_typedesc.mk
diff options
context:
space:
mode:
Diffstat (limited to 'ridljar/JunitTest_typedesc.mk')
-rw-r--r--ridljar/JunitTest_typedesc.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/ridljar/JunitTest_typedesc.mk b/ridljar/JunitTest_typedesc.mk
new file mode 100644
index 000000000..4497731aa
--- /dev/null
+++ b/ridljar/JunitTest_typedesc.mk
@@ -0,0 +1,24 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_JunitTest_JunitTest,ridljar_typedesc))
+
+$(eval $(call gb_JunitTest_use_jars,ridljar_typedesc,\
+ libreoffice \
+))
+
+$(eval $(call gb_JunitTest_add_sourcefiles,ridljar_typedesc,\
+ ridljar/test/com/sun/star/lib/uno/typedesc/TypeDescription_Test \
+))
+
+$(eval $(call gb_JunitTest_add_classes,ridljar_typedesc,\
+ com.sun.star.lib.uno.typedesc.TypeDescription_Test \
+))
+
+# vim:set noet sw=4 ts=4: