summaryrefslogtreecommitdiffstats
path: root/salhelper/CppunitTest_salhelper_testapi.mk
diff options
context:
space:
mode:
Diffstat (limited to 'salhelper/CppunitTest_salhelper_testapi.mk')
-rw-r--r--salhelper/CppunitTest_salhelper_testapi.mk29
1 files changed, 29 insertions, 0 deletions
diff --git a/salhelper/CppunitTest_salhelper_testapi.mk b/salhelper/CppunitTest_salhelper_testapi.mk
new file mode 100644
index 000000000..f3d98aa43
--- /dev/null
+++ b/salhelper/CppunitTest_salhelper_testapi.mk
@@ -0,0 +1,29 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# Major Contributor(s):
+# Copyright (C) 2012 Radu Ioan <ioan.radu.g@gmail.com> (initial developer)
+#
+# All Rights Reserved.
+#
+# For minor contributions see the git repository.
+
+$(eval $(call gb_CppunitTest_CppunitTest,salhelper_testapi))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,salhelper_testapi,\
+ salhelper/qa/test_api \
+))
+
+$(eval $(call gb_CppunitTest_use_external,salhelper_testapi,boost_headers))
+
+$(eval $(call gb_CppunitTest_use_libraries,salhelper_testapi,\
+ salhelper \
+ sal \
+))
+
+# vim: set noet sw=4 ts=4: