summaryrefslogtreecommitdiffstats
path: root/salhelper/test/Symbols
diff options
context:
space:
mode:
Diffstat (limited to 'salhelper/test/Symbols')
-rw-r--r--salhelper/test/Symbols/loader.cxx56
-rw-r--r--salhelper/test/Symbols/makefile.mk85
-rw-r--r--salhelper/test/Symbols/samplelib.cxx53
-rw-r--r--salhelper/test/Symbols/samplelib.hxx40
4 files changed, 234 insertions, 0 deletions
diff --git a/salhelper/test/Symbols/loader.cxx b/salhelper/test/Symbols/loader.cxx
new file mode 100644
index 000000000..a0bfc50fa
--- /dev/null
+++ b/salhelper/test/Symbols/loader.cxx
@@ -0,0 +1,56 @@
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
+/*
+ * This file is part of the LibreOffice project.
+ *
+ * This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * This file incorporates work covered by the following license notice:
+ *
+ * Licensed to the Apache Software Foundation (ASF) under one or more
+ * contributor license agreements. See the NOTICE file distributed
+ * with this work for additional information regarding copyright
+ * ownership. The ASF licenses this file to you under the Apache
+ * License, Version 2.0 (the "License"); you may not use this file
+ * except in compliance with the License. You may obtain a copy of
+ * the License at http://www.apache.org/licenses/LICENSE-2.0 .
+ */
+
+#include <salhelper/dynload.hxx>
+#include <rtl/ustring>
+#include "samplelib.hxx"
+
+using namespace salhelper;
+
+using OUString;
+
+
+class SampleLibLoader
+ : public ::salhelper::ODynamicLoader<SampleLib_Api>
+{
+public:
+ SampleLibLoader():
+ ::salhelper::ODynamicLoader<SampleLib_Api>
+ (OUString( SAL_MODULENAME( "samplelib") ),
+ OUString( SAMPLELIB_INIT_FUNCTION_NAME ))
+ {}
+
+};
+
+
+int main( int argc, char *argv[ ], char *envp[ ] )
+{
+ SampleLibLoader Loader;
+ SampleLibLoader Loader2;
+ Loader= Loader2;
+ SampleLib_Api *pApi= Loader.getApi();
+
+ sal_Int32 retint= pApi->funcA( 10);
+ double retdouble= pApi->funcB( 3.14);
+
+
+ return 0;
+}
+
+/* vim:set shiftwidth=4 softtabstop=4 expandtab: */
diff --git a/salhelper/test/Symbols/makefile.mk b/salhelper/test/Symbols/makefile.mk
new file mode 100644
index 000000000..acfa20d92
--- /dev/null
+++ b/salhelper/test/Symbols/makefile.mk
@@ -0,0 +1,85 @@
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+
+PRJ=..$/..$/
+
+PRJNAME=salhelper
+TARGET=dynloader
+TARGET1=samplelib
+TARGETTYPE=CUI
+LIBTARGET=NO
+
+ENABLE_EXCEPTIONS=TRUE
+
+# --- Settings ---
+
+.INCLUDE : settings.mk
+
+# --- Files ---
+
+#RTTI on
+.IF "$(OS)" == "WNT"
+CFLAGS+= -GR
+.ENDIF
+
+
+#---------------------------------------------------------------------------
+# Build the test library which is loaded by the
+# RealDynamicLoader
+
+SLOFILES= $(SLO)$/samplelib.obj
+
+LIB1TARGET= $(SLB)$/$(TARGET1).lib
+LIB1OBJFILES= $(SLOFILES)
+
+
+SHL1TARGET= $(TARGET1)
+
+SHL1STDLIBS= \
+ $(SALLIB)
+
+SHL1DEPN=
+SHL1IMPLIB= i$(TARGET1)
+SHL1LIBS= $(SLB)$/$(TARGET1).lib
+SHL1DEF= $(MISC)$/$(SHL1TARGET).def
+
+DEF1NAME= $(SHL1TARGET)
+DEFLIB1NAME= $(TARGET1)
+DEF1DEPN= $(MISC)$/$(SHL1TARGET).flt
+
+# ------------------------------------------------------------------------------
+
+OBJFILES= $(OBJ)$/loader.obj
+
+APP1TARGET= $(TARGET)
+APP1OBJS= $(OBJFILES)
+
+APP1STDLIBS= \
+ $(SALHELPERLIB) \
+ $(SALLIB)
+
+APP1DEF= $(MISC)\$(APP1TARGET).def
+
+# --- Targets ---
+
+.INCLUDE : target.mk
+
+$(MISC)$/$(SHL1TARGET).flt: makefile.mk
+ @echo ------------------------------
+ @echo Making: $@
+ @echo __CT>>$@
diff --git a/salhelper/test/Symbols/samplelib.cxx b/salhelper/test/Symbols/samplelib.cxx
new file mode 100644
index 000000000..f904d43eb
--- /dev/null
+++ b/salhelper/test/Symbols/samplelib.cxx
@@ -0,0 +1,53 @@
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
+/*
+ * This file is part of the LibreOffice project.
+ *
+ * This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * This file incorporates work covered by the following license notice:
+ *
+ * Licensed to the Apache Software Foundation (ASF) under one or more
+ * contributor license agreements. See the NOTICE file distributed
+ * with this work for additional information regarding copyright
+ * ownership. The ASF licenses this file to you under the Apache
+ * License, Version 2.0 (the "License"); you may not use this file
+ * except in compliance with the License. You may obtain a copy of
+ * the License at http://www.apache.org/licenses/LICENSE-2.0 .
+ */
+
+#include "samplelib.hxx"
+#include <sal/types.h>
+
+extern "C"
+SampleLib_Api* SAL_CALL initSampleLibApi()
+{
+ static SampleLib_Api aApi= {0,0};
+ if (!aApi.funcA)
+ {
+ aApi.funcA= &funcA;
+ aApi.funcB= &funcB;
+ return (&aApi);
+ }
+ else
+ {
+ return (&aApi);
+ }
+
+}
+
+
+sal_Int32 SAL_CALL funcA( sal_Int32 a)
+{
+ return a;
+}
+
+
+double SAL_CALL funcB( double a)
+{
+ return a;
+}
+
+
+/* vim:set shiftwidth=4 softtabstop=4 expandtab: */
diff --git a/salhelper/test/Symbols/samplelib.hxx b/salhelper/test/Symbols/samplelib.hxx
new file mode 100644
index 000000000..99dc0f6f7
--- /dev/null
+++ b/salhelper/test/Symbols/samplelib.hxx
@@ -0,0 +1,40 @@
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
+/*
+ * This file is part of the LibreOffice project.
+ *
+ * This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * This file incorporates work covered by the following license notice:
+ *
+ * Licensed to the Apache Software Foundation (ASF) under one or more
+ * contributor license agreements. See the NOTICE file distributed
+ * with this work for additional information regarding copyright
+ * ownership. The ASF licenses this file to you under the Apache
+ * License, Version 2.0 (the "License"); you may not use this file
+ * except in compliance with the License. You may obtain a copy of
+ * the License at http://www.apache.org/licenses/LICENSE-2.0 .
+ */
+
+#ifndef INCLUDED_SALHELPER_TEST_SYMBOLS_SAMPLELIB_HXX
+#define INCLUDED_SALHELPER_TEST_SYMBOLS_SAMPLELIB_HXX
+
+#include <sal/types.h>
+
+struct SampleLib_Api
+{
+ sal_Int32 (*funcA)(sal_Int32);
+ double (*funcB)(double);
+};
+
+typedef SampleLib_Api* (*InitSampleLib_Api)(void);
+
+#define SAMPLELIB_INIT_FUNCTION_NAME "initSampleLibApi"
+
+sal_Int32 funcA(sal_Int32 a);
+double funcB(double a);
+
+#endif
+
+/* vim:set shiftwidth=4 softtabstop=4 expandtab: */