summaryrefslogtreecommitdiffstats
path: root/salhelper/test/rtti
diff options
context:
space:
mode:
Diffstat (limited to 'salhelper/test/rtti')
-rw-r--r--salhelper/test/rtti/exports.dxp6
-rw-r--r--salhelper/test/rtti/makefile.mk92
-rw-r--r--salhelper/test/rtti/rttitest.cxx38
-rw-r--r--salhelper/test/rtti/samplelibrtti.cxx51
-rw-r--r--salhelper/test/rtti/samplelibrtti.hxx45
-rw-r--r--salhelper/test/rtti/sols.map48
6 files changed, 280 insertions, 0 deletions
diff --git a/salhelper/test/rtti/exports.dxp b/salhelper/test/rtti/exports.dxp
new file mode 100644
index 000000000..beafa6a1c
--- /dev/null
+++ b/salhelper/test/rtti/exports.dxp
@@ -0,0 +1,6 @@
+?funcA@MyClassA@@UAEXXZ
+?funcB@MyClassA@@UAEXXZ
+?funcC@MyClassA@@MAEXXZ
+?funcA@MyClassB@@UAEXXZ
+?funcB@MyClassB@@UAEXXZ
+?funcC@MyClassB@@MAEXXZ
diff --git a/salhelper/test/rtti/makefile.mk b/salhelper/test/rtti/makefile.mk
new file mode 100644
index 000000000..dd811d531
--- /dev/null
+++ b/salhelper/test/rtti/makefile.mk
@@ -0,0 +1,92 @@
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+PRJ=..$/..
+
+PRJNAME= salhelper
+TARGET= rtti
+TARGET1=samplelibrtti
+LIBTARGET=NO
+TARGETTYPE=CUI
+
+
+ENABLE_EXCEPTIONS=TRUE
+
+USE_DEFFILE= TRUE
+
+# --- Settings -----------------------------------------------------
+
+.INCLUDE : settings.mk
+
+# --- Files --------------------------------------------------------
+
+#RTTI on
+.IF "$(OS)" == "WNT"
+CFLAGS+= -GR
+.ENDIF
+
+SLOFILES= \
+ $(SLO)$/samplelibrtti.obj
+
+LIB1TARGET=$(SLB)$/$(TARGET1).lib
+LIB1OBJFILES= \
+ $(SLO)$/samplelibrtti.obj
+
+SHL1TARGET= $(TARGET1)
+
+SHL1STDLIBS= \
+ $(CPPULIB) \
+ $(CPPUHELPERLIB) \
+ $(SALLIB)
+
+
+SHL1DEPN=
+SHL1IMPLIB= i$(TARGET1)
+SHL1LIBS= $(SLB)$/$(TARGET1).lib
+SHL1DEF= $(MISC)$/$(SHL1TARGET).def
+DEF1EXPORTFILE= exports.dxp
+
+DEF1NAME= $(SHL1TARGET)
+
+.IF "$(OS)$(CPUNAME)"=="SOLARISSPARC"
+SHL1VERSIONMAP= sols.map
+.ENDIF
+
+
+# ------------------------------------------------------------------
+
+APP1NOSAL=TRUE
+
+APP1TARGET= $(TARGET)
+
+APP1OBJS= $(OBJ)$/rttitest.obj
+
+APP1STDLIBS= \
+ $(SALLIB) \
+ $(CPPUHELPERLIB) \
+ $(CPPULIB)
+
+.IF "$(OS)" == "WNT"
+APP1STDLIBS+= $(LB)$/isamplelibrtti.lib
+.ELSE
+APP1STDLIBS+= -lsamplelibrtti
+.ENDIF
+
+# --- Targets ------------------------------------------------------
+
+.INCLUDE : target.mk
+
diff --git a/salhelper/test/rtti/rttitest.cxx b/salhelper/test/rtti/rttitest.cxx
new file mode 100644
index 000000000..0e0665003
--- /dev/null
+++ b/salhelper/test/rtti/rttitest.cxx
@@ -0,0 +1,38 @@
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
+/*
+ * This file is part of the LibreOffice project.
+ *
+ * This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * This file incorporates work covered by the following license notice:
+ *
+ * Licensed to the Apache Software Foundation (ASF) under one or more
+ * contributor license agreements. See the NOTICE file distributed
+ * with this work for additional information regarding copyright
+ * ownership. The ASF licenses this file to you under the Apache
+ * License, Version 2.0 (the "License"); you may not use this file
+ * except in compliance with the License. You may obtain a copy of
+ * the License at http://www.apache.org/licenses/LICENSE-2.0 .
+ */
+
+#include <stdio.h>
+#include <typeinfo>
+
+int main()
+{
+ MyClassB b;
+ MyClassA* pA = &b;
+ // test the virtual function
+ pA->funcA();
+
+ if (typeid(b) == typeid(pA))
+ printf("\nsame types");
+
+ MyClassB* pB = dynamic_cast<MyClassB*>(pA);
+ pB->funcA();
+ return 0;
+}
+
+/* vim:set shiftwidth=4 softtabstop=4 expandtab: */
diff --git a/salhelper/test/rtti/samplelibrtti.cxx b/salhelper/test/rtti/samplelibrtti.cxx
new file mode 100644
index 000000000..c148eb69b
--- /dev/null
+++ b/salhelper/test/rtti/samplelibrtti.cxx
@@ -0,0 +1,51 @@
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
+/*
+ * This file is part of the LibreOffice project.
+ *
+ * This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * This file incorporates work covered by the following license notice:
+ *
+ * Licensed to the Apache Software Foundation (ASF) under one or more
+ * contributor license agreements. See the NOTICE file distributed
+ * with this work for additional information regarding copyright
+ * ownership. The ASF licenses this file to you under the Apache
+ * License, Version 2.0 (the "License"); you may not use this file
+ * except in compliance with the License. You may obtain a copy of
+ * the License at http://www.apache.org/licenses/LICENSE-2.0 .
+ */
+
+#include <stdio.h>
+
+// MyClassA =============================================================
+void MyClassA::funcA()
+{
+ printf("MyClassA::funcA \n");
+}
+
+void MyClassA::funcB()
+{
+}
+
+void MyClassA::funcC()
+{
+}
+
+// MyClassB ===============================================================
+void MyClassB::funcA()
+{
+
+ printf("MyClassA::funcB \n");
+}
+
+void MyClassB::funcB()
+{
+}
+
+void MyClassB::funcC()
+{
+}
+
+/* vim:set shiftwidth=4 softtabstop=4 expandtab: */
diff --git a/salhelper/test/rtti/samplelibrtti.hxx b/salhelper/test/rtti/samplelibrtti.hxx
new file mode 100644
index 000000000..b6bbe6222
--- /dev/null
+++ b/salhelper/test/rtti/samplelibrtti.hxx
@@ -0,0 +1,45 @@
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
+/*
+ * This file is part of the LibreOffice project.
+ *
+ * This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * This file incorporates work covered by the following license notice:
+ *
+ * Licensed to the Apache Software Foundation (ASF) under one or more
+ * contributor license agreements. See the NOTICE file distributed
+ * with this work for additional information regarding copyright
+ * ownership. The ASF licenses this file to you under the Apache
+ * License, Version 2.0 (the "License"); you may not use this file
+ * except in compliance with the License. You may obtain a copy of
+ * the License at http://www.apache.org/licenses/LICENSE-2.0 .
+ */
+
+#ifndef INCLUDED_SALHELPER_TEST_RTTI_SAMPLELIBRTTI_HXX
+#define INCLUDED_SALHELPER_TEST_RTTI_SAMPLELIBRTTI_HXX
+
+class MyClassA
+{
+public:
+ virtual void funcA();
+ virtual void funcB();
+
+protected:
+ virtual void funcC();
+};
+
+class MyClassB : public MyClassA
+{
+public:
+ virtual void funcA();
+ virtual void funcB();
+
+protected:
+ virtual void funcC();
+};
+
+#endif
+
+/* vim:set shiftwidth=4 softtabstop=4 expandtab: */
diff --git a/salhelper/test/rtti/sols.map b/salhelper/test/rtti/sols.map
new file mode 100644
index 000000000..b4b9cf95a
--- /dev/null
+++ b/salhelper/test/rtti/sols.map
@@ -0,0 +1,48 @@
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# This file incorporates work covered by the following license notice:
+#
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed
+# with this work for additional information regarding copyright
+# ownership. The ASF licenses this file to you under the Apache
+# License, Version 2.0 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.apache.org/licenses/LICENSE-2.0 .
+#
+UDK_3_0_0 {
+ global:
+_fini;
+_init;
+
+__1cIMyClassAFfuncA6M_v_;
+__1cIMyClassAFfuncB6M_v_;
+__1cIMyClassAFfuncC6M_v_;
+__1cIMyClassAG__vtbl_;
+__1cIMyClassBFfuncA6M_v_;
+__1cIMyClassBFfuncB6M_v_;
+__1cIMyClassBFfuncC6M_v_;
+__1cIMyClassBG__vtbl_;
+__RTTI__1CpknIMyClassA_;
+__RTTI__1CpknIMyClassB_;
+__RTTI__1CpnIMyClassA_;
+__RTTI__1CpnIMyClassB_;
+__RTTI__1nIMyClassA_;
+__RTTI__1nIMyClassB_;
+
+local:
+ *;
+};
+
+
+
+
+
+
+
+