summaryrefslogtreecommitdiffstats
path: root/sax/CppunitTest_sax.mk
diff options
context:
space:
mode:
Diffstat (limited to 'sax/CppunitTest_sax.mk')
-rw-r--r--sax/CppunitTest_sax.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/sax/CppunitTest_sax.mk b/sax/CppunitTest_sax.mk
new file mode 100644
index 000000000..282ba2414
--- /dev/null
+++ b/sax/CppunitTest_sax.mk
@@ -0,0 +1,30 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CppunitTest_CppunitTest,sax))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,sax))
+
+$(eval $(call gb_CppunitTest_use_external,sax,boost_headers))
+
+$(eval $(call gb_CppunitTest_use_common_precompiled_header,sax))
+
+$(eval $(call gb_CppunitTest_use_libraries,sax, \
+ sax \
+ sal \
+ comphelper \
+ cppu \
+))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,sax, \
+ sax/qa/cppunit/test_converter \
+))
+
+
+# vim: set noet sw=4 ts=4: