summaryrefslogtreecommitdiffstats
path: root/sax/CppunitTest_sax_parser.mk
diff options
context:
space:
mode:
Diffstat (limited to 'sax/CppunitTest_sax_parser.mk')
-rw-r--r--sax/CppunitTest_sax_parser.mk49
1 files changed, 49 insertions, 0 deletions
diff --git a/sax/CppunitTest_sax_parser.mk b/sax/CppunitTest_sax_parser.mk
new file mode 100644
index 000000000..59a90fd13
--- /dev/null
+++ b/sax/CppunitTest_sax_parser.mk
@@ -0,0 +1,49 @@
+# -*- Mode: makefile-gmake; tab-width: 4; indent-tabs-mode: t -*-
+#
+# This file is part of the LibreOffice project.
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+
+$(eval $(call gb_CppunitTest_CppunitTest,sax_parser))
+
+$(eval $(call gb_CppunitTest_use_common_precompiled_header,sax_parser))
+
+$(eval $(call gb_CppunitTest_add_exception_objects,sax_parser, \
+ sax/qa/cppunit/parser \
+))
+
+$(eval $(call gb_CppunitTest_use_libraries,sax_parser, \
+ comphelper \
+ cppu \
+ cppuhelper \
+ unotest \
+ expwrap \
+ sal \
+ sax \
+ test \
+))
+
+$(eval $(call gb_CppunitTest_use_externals,sax_parser, \
+ boost_headers \
+))
+
+$(eval $(call gb_CppunitTest_use_sdk_api,sax_parser))
+
+$(eval $(call gb_CppunitTest_use_ure,sax_parser))
+$(eval $(call gb_CppunitTest_use_vcl,sax_parser))
+
+$(eval $(call gb_CppunitTest_use_components,sax_parser,\
+ configmgr/source/configmgr \
+ framework/util/fwk \
+ i18npool/util/i18npool \
+ sfx2/util/sfx \
+ ucb/source/core/ucb1 \
+ ucb/source/ucp/file/ucpfile1 \
+))
+
+$(eval $(call gb_CppunitTest_use_configuration,sax_parser))
+
+# vim: set noet sw=4 ts=4: